Comparaison de matrice "<>Oui" marche alors que <>A1, quand A1 contient Oui...

0

Bonjour,

J'aime bien excel mais là je bloque...

J'essaie de compter le nombre de ligne respectant plusieurs critères avec =NB.SI.ENS().

Un des critères porte sur la présence de "Oui" ou autre chose (Non;Att;SO;""). La ligne ne devant pas être comptée s'il y a la présence de "Oui"

La condition "<>Oui" marche mais j'aimerais automatiser pour pouvoir changer la valeur "Oui".

Ainsi écrire Oui dans A1 et écrire <>A1 dans NB.SI.ENS() :

=NB.SI.ENS(B1:B28;<>A1;C1;C28;...)

Mais ça en marche pas.

J'ai essayé avec NON(A1) mais il faut une chaine de caractère et pas un booléen.

J'ai cherché une fonction =DIFF(), =AUTRE(), mais elles n'existent pas.

Je suis sur Excel 365, en format .xlsx

Pourriez-vous m'aider ?

Je vous remercie grandement.

Posté le 3 juin, 13:15
par Gabicha
Répondre
0

Bonjour,

Pour exemple avec A1 contenant une variable

=NB.SI.ENS(B1:B28;"<>" & A1)

Posté le 3 juin, 18:45
0

Bonjour,

Waw, ça marche !

Merci beaucoup beaucoup beaucoup !

Posté le 7 juin, 09:26
par Gabicha

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :