Créer une règle pour mise à jour automatique

1

Bonjour,

Voilà mon problème. J'aimerai avoir deux tableaux :

  • le premier contient des personnes appartenant à des catégories
  • le deuxième contient le nombre de personnes par catégorie

Exemple :

Dans le premier tableau on a Mr X appartenant à la catégorie A et Mr Y appartenant à la catégorie B. Imaginons qu'on ajoute un Mr Z à la catégorie A, comment peut-on faire pour que dans le second tableau, la ligne contenant le nombre de personnes de la catégorie A passe de 1 à 2, de manière automatique quand on modifie le premier tableau?

Merci

Posté le 29 mai 2015, 18:22
par ddg13
Répondre
2

Le tableau 2 ne se mettra à jour que si il est ouvert lors de la modification, ou lors de sa prochaine ouverture. Les solutions possibles seraient de mettre le tableau 2 dans un un onglet du tableau 1, ou de faire une macro qui ouvre le tableau 2 et le referme, mais c'est plus lourd sur l'ordi, et gênant quand on travaille. Si tu ne veux vraiment pas les mettre dans le même fichier, ouvre les deux et laisse le 2 en fond.

azerty11235 Posté le 29 mai 2015, 22:40
par azerty11235
  • Les deux tableaux peuvent être dans le même fichier il n'y a pas de problème, Par contre ce que je sais pas faire c'est créer la règle ou la formule permettant cela ? – ddg13 1 juin 2015, 13:23
0

Supposons que la colonne B contient la catégorie, dans le tableau de comptage saisir une formule du type :

=NB.SI(B2:B100;«A»)
Posté le 30 mai 2015, 07:54
par ouisansdoute
  • Je n'arrive pas à utiliser cette formule, peux-tu me décrire de manière plus détaillée la procédure s'il te plait ? – ddg13 1 juin 2015, 13:23

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :