Ignorer une cellule vide dans un calcul

0

Bonjour à tous,

Après plusieurs recherches sur internet je suis toujours en difficulté.

Je possède un calcul simple qui est =E5+I5+J5+K5+L5+M5 sauf que dans mon tableau je peux avoir des cellules vide comme par exemple E5 ou L5 ou d'autres.

Petit exemple disons que chacune est égale à 1.
Logiquement je tombe sur 6.

Du coup je souhaiterais dire à Excel quand une cellule est vide ou possède une erreur (#N/A (c'est normal)) alors ignorer cette cellule.

Petit exemple si E5 et vide ou possède une erreur le résultat sera 5 car il aura ignoré E5.

Car la j'ai des erreurs ou des cellules vides et don le résultat de mon =E5+I5+J5+K5+L5+M5 est #N/A

Merci

    Posté le 10 novembre, 14:43
    par Alexandre
    Répondre
    0

    Bonjour Alexandre,

    je te propose cette formule : =SOMME(E5;i5:M5)

    attention : il y a un point-virgule ( ; ) après E5 et un deux points ( : ) entre i5 et M5.

    ça marchera même si une cellule est vide ou contient une valeur d'erreur telle que #N/A.

    note que si une cellule est vide, sa valeur numérique est 0 ; en voici la preuve :
    A1 est une cellule vide ; en B1 : =10+A1 retourne 10+0 = 10.

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    tu as écrit : « ou possède une erreur (#N/A (c'est normal)) »

    * si tu as saisi toi-même cette valeur d'erreur avec #N/A ou avec =NA() : ok, c'est ce que tu veux.

    * si ce #N/A est le résultat d'une formule, tu peux l'éviter avec : =SIERREUR(ta_formule;"")
    ou peut-être avec une autre méthode : c'est selon la façon dont est produit ce #N/A.

    * rappel : #N/A signifie Non Available (Non disponible) ; on peut vouloir le saisir manuellement
    pour indiquer qu'une donnée n'est pas disponible sur le moment, mais qu'elle le sera ensuite.

    rhodo

    rhodo Posté le 10 novembre, 15:39
    par rhodo

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :