Modifier une formule =NB.VIDE()

-1

Bonjour, 

Compter les cellules vides par rapport au mois en cours, voir descriptif dans le fichier joint 

Lien Voir ICI

Merci par avance

Cordialement

    tontonbox Posté le 7 janvier, 22:45
    par tontonbox
    Répondre
    -1

    Bonjour tontonbox,

    ton fichier en retour : https://www.cjoint.com/c/MAhxW3OzKG0

    en A5, il y a 1 ➯ en AJ6, il y a 28 ; en A5, choisis 2 ➯ en AJ6, il y a 25 ;
    formule en AJ6 : =JOUR(FIN.MOIS(DATE(A1;A5;1);0))-NBVAL(E6:AI6)

    pour une année bissextile, ça marchera aussi car grâce à FIN.MOIS(),
    pour le mois de février, ça retournera bien 29 jours (au lieu de 28).

    bonne année 2023, et meilleurs vœux.  :)

    rhodo

    rhodo Posté le 8 janvier, 00:54
    par rhodo
    • Bonjour à tous & bonne année Une autre formule =NB.SI(E5:AI5;">"&0)-NBVAL(E6:AI6) – 8 janvier, 07:48
    -1

    Bonjour Rhodo,

    Que dire de plus..... Parfait! Parfait! exactement le résultat escompté 

    Merci pour ce nouveau challenge 2023, soldé de façon optimale

    Merci  

    Bonne année 2023, & meilleurs vœux 

    tontonbox Posté le 8 janvier, 12:00
    par tontonbox
    -1

    Rebonjour,

    voici une 2ème version : https://www.cjoint.com/c/MAinEzhaSs0

    je n'avais pas pensé à utiliser la ligne 5, comme ça l'est pour la 2ème formule proposée ;
    en me basant dessus, je propose dans le fichier ci-dessus cette autre formule :

    =NB(E5:AI5)-NBVAL(E6:AI6)

    en A5, il y a 2 pour le mois de février ; en A1, j'ai mis l'année 2024 car c'est une année
    bissextile ; en E5:AI5, il y a bien 29 jours : c'est jusqu'au jeudi 29 ➯ en AJ6 : 26.

    ainsi, les 2 formules sans FIN.MOIS() sont plus simples, et marchent aussi pour des
    années bissextiles.

    rhodo

    rhodo Posté le 8 janvier, 14:43
    par rhodo
    -1

    Re-Rhodo

    Super! Merci pour la deuxième version, qui est plus simple et aussi efficace à utiliser à mon niveau.

    Merci pour le temps que tu m'as consacré 

    Cordialement

    tontonbox Posté le 8 janvier, 16:39
    par tontonbox

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :