Sous-totaux de séquences tronquées en ligne

-2

Bonjour,

Je voudrai afficher le total de chaque série de chiffres placés sur une même ligne :

Données :   2 2 2   2 2     2 2 2 2       2
Résultat souhaité :       6     4           8       2

Et après cela, je souhaiterai afficher dans une cellule à part, la valeur la plus élevée.

Je vous remercie. Yolane

Posté le 31 décembre 2015, 12:44
par Yolane
Répondre
0

Bonjour,

les données se trouve en A1 à A4

Pour le résultat,

en A2 : =SOMME(0+STXT(A1;LIGNE(DECALER($A$1;;;NBCAR(A1)) );1))

en B2: =SOMME(0+STXT(B1;LIGNE(DECALER($A$1;;;NBCAR(B1)) );1))

en C2 : =SOMME(0+STXT(C1;LIGNE(DECALER($A$1;;;NBCAR(C1)) );1))

en D2 : =SOMME(0+STXT(D1;LIGNE(DECALER($A$1;;;NBCAR(D1)) );1))

les formules sont à valider par CTRL + MAJ et ENTER (matricielle)

pour le MAX, à mettre dans une cellule

=MAX(A2:D2)



M12 Posté le 4 mars 2016, 08:12
par M12

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :