Comparer des valeurs dans une colonne

2

Bonjour,

J'ai réalisé un tableau qui récapitule, pour toutes les pièces que j'ai fabriquées, le numéro du certificat utilisé par couche de peinture, sachant qu'il y a 3 couches par pièces.

Extrait de mon tableau pour 2 pièces :

A B C D
1 Pièce Couche de peinture Certificat
2 S4042/002 IND 2A 1 18449 conforme
3 S4042/002 IND 2A 2 18449 non conforme
4 S4042/002 IND 2A 3 18447 non conforme
5 S2412/057 IND 1A 1 18183 conforme
6 S2412/057 IND 1A 2 18183 non conforme
7 S2412/057 IND 1A 3 18115 non conforme

J'aimerais pouvoir vérifier que le numéro de certificat de la couche 1 et de la couche 2 est le même pour toutes mes pièces.

J'avais pensé à faire la formule suivante : SI(D2=D3;"conforme";"non conforme")

Mon problème est au moment ou j'étends la formule sur la colonne, pour la ligne 2 et 5 c'est bon mais pas pour la ligne 4 et 6.

Pouvez-vous m'aider à trouver la bonne formule ?

Merci

Posté le 8 février 2016, 16:23
par Volvic
Répondre
0

Si tu as toujours 3 couches de peinture, alors je crois qu'il serait beaucoup plus simple d'avoir une seule pièce par ligne avec 6 colonnes pour les 3 couches de peinture (2 colonnes par couche : n° de couche + certificat). De cette manière tu pourrais facilement comparer les couches d'une même pièce.

Sinon, tu peux activer la comparaison uniquement usr les lignes de couche de peinture n°1 :

=SI(B2=1;SI(D2=D3;"conforme";"non conforme");"N/A")

Pour faire quelque chose de plus élaboré, je crois qu'il faudrait passer par la fonction RECHERCHEV pour rechercher l'autre valeur à comparer.

Vince Posté le 9 février 2016, 18:33
par Vince
0

bonjour,

je pars du postulat que la 1ere couche de peinture a les bonnes infos, sinon ... on est mal :-(

pour cela j'utilise la fonction nb.si pour comparer le numero de peinture au reste et savoir si =3 alors c'est le 1er, je mets "conforme"

puis je compare les autres lignes a celles du dessus et je fais la différence.

=SI(NB.SI(A2:A9;A2)=3;"conforme";SI(ET(A2=A1;C2=C1);"conforme";"non conforme"))

Pièce Couche de peinture Certificat
S4042/002 IND 2A 1 18449 conforme
S4042/002 IND 2A 2 18449 conforme
S4042/002 IND 2A 3 18447 non conforme
S2412/057 IND 1A 1 18183 conforme
S2412/057 IND 1A 2 18183 conforme
S2412/057 IND 1A 3 18115 non conforme

dis moi si cela te convient ?


mrsurf Posté le 18 février 2016, 13:40
par mrsurf
1

Bonsoir,

Si j'ai bien compris l'application, nous trouvons le numéro de couche en dernière position du numéro de pièce.

Je propose donc la solution suivante :

http://www.cjoint.com/c/FBsq1RWL3sa

Cliques sur le lien et suis les instructions et tu récupéreras un classeur Excel avec ma proposition.

J'ai ajouté un petit contrôle au cas où, par mégarde, on encoderait un numéro de couche inexistant (dans l'exemple 4).

J'ai supposé aussi que la troisième couche ne devait pas avoir "non conforme" puisqu'elle ne fait pas l'objet d'un contrôle.  J'ai remplacé par "3 couche".  Si pas bon, il suffit de changer le libellé dans la formule. 

Merci de confirmer si cela correspond à tes souhaits.

A+

Chris

Posté le 18 février 2016, 18:01

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :