Formule de somme sous condition

-1

Bonsoir,

J'ai réalisé un bulletin scolaire sur excel dans lequel figure une cellule que je nommerai (x) représentant la somme de moyennes de matières et je souhaiterai ajouter à cette somme une valeur qui figure également sur ce tableau dans la cellule (y); c'est une note sur 20.

Cependant, je ne dois ajouter que l'unité de la note et uniquement lorsque cette dernière dépasse 10/20. Si la note est 10.50, je n'ajoute que 0.5 au résultat de la somme dans (x); si elle est de 13, je n'ajoute que 3 etc.

Comment dois-je écrire la formule sachant que la formule de la somme sur mon tableau est =SOMME(D11;D12;D13;D14;D15;D16;D17;D18;D19;D20) ?

Je vous remercie pour votre réponse.

Posté le 12 février 2016, 21:44
par bookatlaz
Répondre
1

Il existe une fonction spécifique pour calculer une somme sous condition dans Excel : SOMME.SI, je ne sais pas si ça peut t'aider.

Vince Posté le 13 février 2016, 01:17
par Vince
1

Bonjour

 Si j'ai bien compris ton problème voila comment je ferais

Notes en colonne A                  Formules en colonne B

8                                                = SI(A2<=10;0;A2-10)       résultat 0

12                                               = SI(A3<=10;0;A3-10)       résultat 2

ect...

puis sommes des 2 colonnes  soit =somme a1: b2( le 2 à modifier en fonction du nombre de lignes)

Cordialement


Posté le 15 février 2016, 13:08
par DETAILLE
1

Bonjour,

Selon ma compréhension de ton problème : 

cellule x : =SOMME(D11;D12;D13;D14;D15;D16;D17;D18;D19;D20)+si(y<10;0;y-10)

A+

Chris

Posté le 18 février 2016, 11:19

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :