mettre une date anterieur par rapport à une autre automatiquement

2

Bonjour,


Je souhaite sur mon fichier que lorsque j'inscris une date en colonne A, qu'apparaisse sur la colonne B, une date anterieur de 6 mois afin que je n'ai plus qu'a trier les dates et je sais quand relancer mes clients.

Merci pour votre aide


Cyril

Posté le 11 juillet 2017, 12:55
par cyril
Répondre
3

Bonjour Cyril,

dans la colonne B en B1 tu mets la formule suivante =SIERREUR(A1+90;"")

puis tu étends jusqu'en bas.

Je t'ai mis SIERREUR comme ça si tu n'a pas encore rempli la colonne A avec une date il ne s'affichera pas 01/01/1900.

Est ce que cette réponse te conviens ?

Cordialement,

Tom

Tom Posté le 11 juillet 2017, 16:58
par Tom
4

Bonjour Cyril

Bonjour Tom

Je comprend différemment ta demande : pour moi il s'agit de trouver une date ANTERIEURE de 6 mois.

Donc il y a 3 moyens :

Solution Tom : en B1 =A1-180 mais tu ne seras pas jour pour jour à cause des mois de 30 et 31 et du mois de février.  183 serait d'ailleurs plus précis mais resterait quand même inexacte

Solution 2 B1 =MOIS.DECALER($A$3;-6) où tu auras un décalage jour pour jour

Solution 3 B1 =FIN.MOIS($A$3;-6) où tu trouveras le décalage de 6 mois mais en trouvant la fin du mois antérieur - cela peut être utile pour rassembler tous les rappels d'un mois et aussi en fonction de tes conditions générales de ventes (échéance fin de mois)

Je te joins un petit tableur avec un exemple de calcul :

http://www.cjoint.com/c/GGmigYfBfif

Il suffit de cliquer sur le lien et de suivre les instructions pour récupérer le fichier.

Dans ce petit tableur, je t'ai permis de paramétrer le nombre de mois en B2 où tu précises le nombre de mois désirés avec un "-" pour  une date antérieur et rien ou + pour une date postérieure.

Comme ici il n'est pas question de dupliquer les formules, je n'ai pas ajouter le test SIERREUR qui reste valable si dans ton application tu désires calculer plusieurs dates.

Pour être complet, il est possible aussi d'extraire les données des clients correspondants à la date mais pour cela il faudrait nous envoyer un exemple de ton fichier (pas toutes les lignes : juste quelques exemples en changeant les noms pour la confidentialité).

Merci de confirmer si cela répond à tes attentes.

A bientôt

Chris


CHRIS Posté le 12 juillet 2017, 10:19
par CHRIS
  • Bien vu Chris, effectivement c'est une date antérieure je me suis trompé de sens et en plus je n'ai mis que 3 mois au lieu de 6. ta solution est mieux. Cordialement, Tom – Tom 12 juillet 2017, 11:07

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :