Localiser les doublons dans une colonne

1

Bonjour,

j'ai le problème suivant :

j'ai une feuille excel avec dans la colonne A une liste de 10 000 mots. 

Je souhaite rechercher les doublons (et il y en a !!) dans cette colonne A, afin de les supprimer si besoin. Les doublons seraient mis en surbrillance mais ce qui m'aiderait beaucoup c'est que dans une colonne B, et dans la cellule à coté de chaque mot cela me met le n° de la cellule ou se trouve le ou les doublons. 

Attention :

- les cellules vides ne doivent pas être prise en compte (car dans ma colonne A il y en a une bonne centaine) 

- les n° de cellules qui sont mis dans la colonne B (et uniquement dans cette colonne) doivent être cliquables pour m'emmener directement à la cellule (sinon je dois monter ou descendre des milliers de lignes avec la souris et c'est pas pratique).

- si il y a plusieurs n° de cellules dans la colonne B, ils peuvent séparer par un espace 

Comme cela je pourrai aller directement sur la ou les cellules où se trouvent les doublons (si les n° de cellules sont cliquables) pour voir si je dois les supprimer ou pas.

J'ai mis un fichier excel pour montrer ce que je recherche.

Merci pour votre aide

Florian


https://www.cjoint.com/c/HAFroFxC01N


    Florian699 Posté le 31 janvier, 18:14
    par Florian699
    Répondre
    1

    Bonjour,

    Je te propose la solution suivante :

    https://www.cjoint.com/c/HBbreFgv0gj

    Plutôt que de rechercher les doublons et puis que tu doives les éliminer, je te confetionne une liste SANS les doublons.

    Inconvénient : j'utilise une formule matricielle et le traitement du calcul est très lourd donc lent.

    Comme je suppose que ce traitement ne doit être fait qu'une seule fois, je te conseille, une fois le traitement effectué sur tes 10.000 lignes, de faire une copie / collage SPECIAL / VALEUR (donc en éliminant les formules et en ne conservant que la valeur des lignes) dans un autre classeur et puis de poursuivre les autres traitements que tu dois faire avec ta liste expurgée.

    Pour ne pas alourdir le transfert du fichier, j'ai limité la duplication de la formule jusqu'à la ligne 101.  Il te faudra la dupliquer jusqu'à la ligne 10.001 par tirage.

    Ne soit pas effrayer par la lenteur de réaction : c'est normal, le traitement des formules matricielles est très lourd.

    Je travaille avec un Excel 2007, j'espère que cela ne te posera pas de problème

    Si tu as besoin de plus d'explications n'hésites pas à me revenir.

    A+

    Chris


    CHRIS Posté le 1 février, 18:18
    par CHRIS
    1

    La formule en C3

    =SI(ESTNA(INDEX(A4:C34;EQUIV(B3;B4:B34;0);1));"";"num " &INDEX(A4:C34;EQUIV(B3;B4:B34;0);1)& ", ligne "&LIGNE(INDEX(A4:C34;EQUIV(B3;B4:B34;0);1)))

    indique le numéro du mot ainsi que la ligne ou se trouve le prochain doublon.

    ouisansdoute Posté le 6 février, 12:52
    par ouisansdoute

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :