Afficher toutes les valeurs d'un tableau suivant une liste

3

Bonjour à tous,

Mon problème est le suivant : j'ai une feuille principale avec comme référence le numéro d'un outil 1, 2 et 3. Et j'ai des variable par exemple le temps d'usinage, de maintenance et réglage.

Mon souhait est de créer une seconde feuille qui vas contenir toutes mes variables donc avec des temps différents selon le numéro de l'outil.

Je veux dans la feuille1 créer une liste déroulante et quand par exemple je choisis l'outil 1 alors les valeurs des d'usinage etc corresponde idem si je choisis le numéro 2 etc

Voici le lien pour exemple

https://www.cjoint.com/c/HDehGOJOJQm

Merci d'avance

Posté le 4 avril 2018, 09:33
par stevie
Répondre
2

Bonjour,

Tu peux le faire facilement avec une fonction RECHERCHEV, à condition que ton tableau feuille 2 soit organisé différemment :

En première ligne de ton tableau de références saisis de A1 à D1 les intitulés de colonne : Outil / Usinage / Maintenance / Réglage

Puis complète chaque ligne du tableau avec les valeurs (en A2 le nom ou numéro de l'outil,  B2 : temps d'usinage ...

Puis sur la feuille 1 tu peux saisir en B3 la formule =RECHERCHEV($B$2;Feuil2!$A$1:$D$12;2;FAUX)

Tu peux encore améliorer en nommant ton tableau de référence d'une manière dynamique (s'il est amené à grandir)

ouisansdoute Posté le 4 avril 2018, 10:20
par ouisansdoute
2

Bonjour merci de votre réponse.

C'est l'inverse que je voudrais, je m'explique ; c'est le nom de l'outil qui doit être modifiable, c'est à dire que je veux modifier le numéro ou nom de l'outil et je veux que les temps d'usinage etc soit associés à l’outil.

Les temps, de réglage, usinage et maintenance seront fixes.

Avez vous une idée dans ce sens ? voir un exemple de tableau c'est plus parlant ^^

Posté le 5 avril 2018, 09:59
par stevie
3

Regarde le fichier joint.https://www.cjoint.com/c/HDfiYQekbgR

ouisansdoute Posté le 5 avril 2018, 10:53
par ouisansdoute
  • Merci ! C'est exactement ce que je voulais. Mon tableau est amené à grandir, tu m'a parlé de tableau dynamique en quoi ça peut m'être utile ? – 5 avril 2018, 14:56

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :