URGENT : Aide fonction RECHERCHE

0

Bonjour à Tous,

J'ai un souci avec la fonction Recherche (H ou V). Je joints le fichier suivant dans lequel, grâce à une formule, je souhaiterai automatiser l'entrée des dates pour chaque formation et chaque salarié. La base de données (1er onglet) contient toutes les données (date de formation). Je souhaite faire apparaître en cellule E16 (voir fichier BASE) la date de formation correspondant au salarié...

J'ai tenter une formule : =SIERREUR(FORMULERECHERCHEV(E5;'Données de base'!A:F;'Données de base'!E:E;FAUX);0) mais j'obtiens la date 00/01/1900 ou RECHERCHEV(E5;'Données de base'!A:F;'Données de base'!E:E;FAUX mais j'obtiens NA !

Quelqu'un pourrait-il m'aider ?

Merci beaucoup d'avance.


https://www.cjoint.com/c/IAvnm3oK1j6

    Posté le 21 janvier, 14:26
    par Line
    Répondre
    0

    Bonjour,

    Tu peux essayer avec cette formule en E16 à valider par CTRL MAJ Entrée (matricielle) et tirer vers le bas, mais sur une grande liste, c'est assez long

    =SIERREUR(INDEX('Données de base'!F:F;EQUIV(BASE!A16&BASE!$E$5;'Données de base'!A:A&'Données de base'!E:E;0));"")

    Posté le 21 janvier, 17:45
    0

    Bonjour,

    Une alternative également avec une formule matricielle et donc procédé comme mon homologue et avec les mêmes remarques (lenteur de calcul):

    =INDEX('Données de base'!F:F;EQUIV(1;('Données de base'!A:A=A16)*('Données de base'!E:E=$E$5);0))

    Tous les chemins mènent à Rome avec Excel...

    Remarque : certains des exemples que tu donnes n'ont pas d'équivalent dans la table

    A+

    Chris

    CHRIS Posté le 22 janvier, 11:04
    par CHRIS
    0

    Bonjour,


    la cellule E5 contient un code module "FRF019".

    Cette valeur est recherchée dans la première colonne de la plage de recherche. Or cette première colonne contient un identifiant type 10025423

    en E16, la formule =RECHERCHEV(A16;'Données de base'!A1:F190314;6;FAUX) semble fonctionner.

    Mais je ne sais pas si c'st le résultat souhaité

    Posté le 2 février, 16:17

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :