Incrémenter valeurs références d'une formule et non son résultat final avec SpinButton

0

Après plusieurs manip et amélioration de mon fichier de statistique physique, je voudrais avoir vos lumières, vos aides et explication sur un problème que je n'arrive pas à solutionner , 
Dans mon fichier de stats, j'ai des cellules avec différentes formules saisies, comme par exemples "=ARRONDI(C4*0.45+D4*0.55,2)"  se trouvant en "A4", Je souhaiterait qu'à l'activation en "C1" d'un SpinButton, celui ci puisse incrémenter non pas le résultat final de la cellule "A4" qui à pour résultat 15, qui augmenterait bien à 16  ou diminuerait à 14, ce qui a pour conséquence d'effacer la formule ci trouvant, donc l'idée voulu, serait plutôt d'incrémenter les valeurs références des cellules "C4 :ayant pour valeur 10" et "D4 : ayant pour valeur 20",  pour valeur 79, pour avoir comme résultat que les deux valeurs 10 et 20 puisse passer en même temps  à +1 > 11 et 21 ou -1 > 9 et 19. 

Question : Faudrait'il pas créer un autre SpinButton "A1"  pour éviter une quelconque interférence avec le SpinButon en "C1" incrémentant les valeurs : Stats1 et 2.

Trouvez mon fichier ci-joint : https://www.cjoint.com/c/IBgvn3gNqIQ

Je reste à l'écoute de toute proposition, amélioration envisageable,
si vous pouvez m'aider je vous en remerciait beaucoup
Bien à vous

    Posté le 6 février, 22:16
    Répondre
    • oups désoler, désoler, désoler j'ai oublier la politesse; Bonjour à tous, – MadMax97 6 février, 22:47
    0

    Bonjour,

    Je ne suis pas certain de bien comprendre ta demande aussi je la reformule selon mon interprétation :

    Tu désires que si l'on clique sur les Spinbuttons, et que la cellule active se trouve dans la colonne C (en C3 par exemple), les cellules C3 et D3 soient agrémentées ou diminuées de 1

    Si la cellule active est dans la colonne D (en D3 par exemple) seule la cellule D3 sera agrémentée (ou diminuée) de 1

    Si c'est cela que tu désires voici l'adaptation du vba à effectuer :

    Private Sub SpinButtonStats_Change()

    If IsNumeric(ActiveCell) Then ActiveCell = ActiveCell + SpinButtonStats

    If ActiveCell.Column = 3 And IsNumeric(ActiveCell.Offset(0, 1)) Then ActiveCell.Offset(0, 1) = ActiveCell.Offset(0, 1) + SpinButtonStats

    SpinButtonStats = 0

    End Sub

    A remarquer qu'avec cette solution tu ne pourras pas agrémenter la colonne C uniquement.

    Quoiqu'il en soit, si je n'ai pas bien interprété ta demande, cette solution t'apporte déjà une méthode pour arriver à tes fins.

    Si tu as besoin de plus d'explications ou si tu veux corriger mon interprétation, n'hésites pas à me revenir.

    A+

    Chris  


    CHRIS Posté le 8 février, 11:35
    par CHRIS

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :