Date de transaction

0

J'ai une colonne de date 

Ce que je veux obtenir c'est que lorsque la date du jour arrive le Résultat est 1 et tout ce qui est avant la date du jour doit etre 0. 

Présentement puisque la formule que j'uilise dans la colonne Résultat est =SI(Date<=Date du jour;1;0) le résultat donne toujours 1 avant la Date du jour.  

=aujourdhui()
Date du jour 
28 février 2019 

Résultat          Date 
0             15 janvier 2019 
0              31 janvier 2019 
0              12 février 2019 
1                28 février 2019 
0                30 mars 2019 
0                30 avril 2019 
0                 30 mai 2019

La formule de la colonne Résultat est =SI(Date<=Date du jour;1;0) 

    Posté le 24 février, 21:13
    par jboudre
    Répondre
    0

    Bonjour

    Patrice33740 Posté le 24 février, 21:40
    par Patrice33740
    0

    Bonjour,

    En supposant les dates dans la colonne A, essaie avec :

    =SI(A1>=AUJOURDHUI();1;0)

    Et cela devrait te donner ce que tu souhaites à savoir 0 pour les dates inférieures à la date du jour et 1 à partir de la date du jour

    Bonne continuation

    Chris


    CHRIS Posté le 25 février, 01:02
    par CHRIS
    • Désolé mais je m'apercois que je n'ai pas mentionné que tout ce qui est AVANT et APRES la date du jour doit etre = à 0. Le seul résultat qui doit me donné 1 est la date du jour Si tu trouve la bonne formule ou un mélange de formule ce serais tres apprécié. Merci – jboudre 25 février, 04:52
    0

    Bonjour,

    C'est simple, il suffit d'enlever le > et la formule devient :

    =SI(A1=AUJOURDHUI();1;0)

    Bonne continuation

    Chris


    CHRIS Posté le 25 février, 18:01
    par CHRIS
    • Conseil : N'utilise pas les commentaires pour répondre car ils n'agrémentent pas le compteur et nous ne nous rendons pas compte que tu as répondu. Utilise "Répondre" A+ – CHRIS 25 février, 18:03
    • Non, parce qu'il me faut un Résultat = 0 APRES la date du jour, 1 à la date du jour meme si celle-ci est différente de la date dans la colonne et 0 AVANT la date du jour Cette formule me donne un Résultat = 0 dans toutes les situations des que la date dans la colonne est différente de la date du jour. Il me faut absolument un Résultat=1 à la date du jour meme si celle-ci est différente de la date inscrite dans la colonne. Merci, il faut chercher encore ... – jboudre 26 février, 02:36
    0

    Bonjour,

    J'essaie de te comprendre... et ce n'est pas facile...

    Veux tu dire que tu encodes une "date du jour " dans une cellule du tableur et qu'il faut comparer à celle-ci ?? et pas à la date du jour où tu encodes et qui est fournie par la fonction AUJOURDHUI() ??

    Si c'est cela, il faudrait me préciser dans quelle cellule se trouve cette date du jour que tu encodes.

    Admettons que la cellule C1 contient la date du jour que tu désires, la formule devient :

    =SI(A1=$C$1;1;0)

    Cela serait plus facile de t'aider si tu pouvais joindre ton fichier.  Pour cela utilises le site https://www.cjoint.com/

    Tu suis les instructions et tu charges le fichier dans cjoint ; tu crées le lien et tu le copie/colle dans le Forum.

    Et je répète : utilise Répondre pour communiquer et pas les commentaires.

    A+

    Chris


    Posté le 26 février, 10:35
    0

    J'explique mal ce que je veux obtenir 
    Tu as raison, la formule fonctionne bien lorsqu'on inscrit toutes les dates du mois dans le tableau. 
    Mais dans mon cas seul les dates de tansaction bancaire (la fin de chaque mois ou quelques dates intermédiaires) sont inscrites. 
    Ce que je veux obtenir, c'est lorsque la date du jour correspond a la date de mon tableau, le résultat est 1 et demeure 1 lorsque la date du jour change, et les autres dates AVANT et APRES soit =0. 
    Lorsque que la prochaine Date du jour correspond à la prochaine date du tableau (30 mars 2019) le Résultat soit=1 et les autres date AVANT et APRES soit =0 

    J'espere que c'est bien expliqué. 


    Merci 

    Date du jour (Exemple) 28 fevrier 2019

    Résultat Date 
    0 15 janvier 2019 
    0 31 janvier 2019 
    0 12 février 2019 
    1 28 février 2019 
    0 30 mars 2019 
    0 30 avril 2019 
    0 30 mai 2019 

    Date du jour (Exemple) 30 mars 2019

    Résultat Date 
    0 15 janvier 2019 
    0 31 janvier 2019 
    0 12 février 2019 
    0 28 février 2019 
    130 mars 2019 
    0 30 avril 2019 
    0 30 mai 2019

    Posté le 26 février, 14:22
    par jboudre
    0

    Bonsoir,

    Désolé mais tes explications sont toujours aussi nébuleuses... 

    Pour moi la formule que je t'ai donnée doit te donner le résultat que tu montres dans ton exemple et je ne comprend pas du tout ou tu veux en venir avec tes explications.

    Ton exemple montre d'ailleurs une date sur toutes les lignes alors que dans tes explications tu sembles dire qu'il y a des lignes sans dates (si j'ai bien compris...)

    Encore une fois : envoie un fichier que l'on puisse concrétiser ta demande.

    Si confidentiel : tu enlèves les données et tu mets des exemples bidons.  Ce qui est important c'est d'avoir la structure de ton classeur Excel avec 2 ou 3 exemples.

    A+

    Chris

    CHRIS Posté le 27 février, 01:24
    par CHRIS
    0

    Voici le fichier. J'espere qu'avec le fichier ce sera plus clair

    Merci

    https://www.cjoint.com/c/IBBlZgDUZ5S

    Posté le 27 février, 12:54
    par jboudre
    • Bonjour Merci a ceux qui m'on envoyer des pistes de solution J'ai réussi a trouver la fonction dans mon fichier . En essayant de faire comprendre le résultat que j'ai besoin, la formule m'est apparu plus clairement =SI(ET(B12<=$B$7;$B$7 – jboudre 28 février, 16:57

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :