Sélectionner les valeurs en doublon de 2 colonnes et faire apparaître une valeur correspondante

1

Bonjour,

Difficile d'expliquer mon problème dans le titre.

Je dois travailler sur 2 plages de données provenant de bases différentes.

La base 1 est l'export d'une base de données de produits d'un site internet (4000 lignes) avec des colonnes pour les références, noms, caractéristiques. 

La base 2 provient d'un classeur excel où sont présents les références ainsi que les prix. Il y a environ 9000 lignes.

Le problème est que certaines références de la base 1 ne sont pas dans la base 2 et inversement. Mon objectif est de relier les prix de la base 2 aux références correspondantes de la base 1 pour ainsi pouvoir copier-coller les lignes de la base 1 avec les PRIX dans un catalogue que je réalise sur ordinateurs.

J'arrive à penser à la formule mais je ne parviens pas à la réaliser.

Elle serait.

Si la valeur de A1 (réf de la base 1) est également présent dans la colonne D (colonne de la réf de la base 2) , alors faire apparaître la valeur de la colonne E (la colonne prix de la base 2) si non, ne rien faire apparaître. 

Je pourrais après facilement retraiter les données et je serais bien content !

Quelqu'un aurait une idée ?

Merci d'avance :)


mrpropre Posté le 6 octobre 2014, 18:36
par mrpropre
Répondre
2
=SI(NB.SI(base2!D:D;base1!A1);RECHERCHEV(A1;base2!D:E;2;0))

Ou plus simple :

=SIERREUR(RECHERCHEV(A1;base2!D:E;2;0);"plouf !")
Steelson Posté le 6 octobre 2014, 19:09
par Steelson
2

Je viens de tester, ça marche super ! plus qu'à trier et filtrer le tout ! 

Merci beaucoup !! :)

Posté le 6 octobre 2014, 21:05
1

j'avais oublié de me connecter ! 

le message précédent est de moi ! 

encore merci !

Posté le 6 octobre 2014, 21:06
par mrpropre

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :