comment comparer des cellule sur des pages differente et renvoyer les resultat en copiant une cellule d'une page sur une autre

0

bonjour


voila mon problème je suis en train de préparer un tableau

dans ce tableau je voudrai qu'en mettant une référence produit cela insert automatiquement le descriptif de ce produit dans la cellule à coté

voila ce que je voudrais faire


dans la feuille magasin mettre un référence produit dans la colonne C

comparer cette référence avec la colonne A de la feuille produits

si égal alors copier la cellule descriptif de cette référence dans la cellule descriptif a coté de la référence que je viens de mettre

j'étais partis sur cela ( étant novice en formule je ne sais pas si cela est exacte)

if Magasin!C3=Produit!C1 then Magasin!D3=Produit!B3

mais je ne sais pas si il faut faire une macro ou une formule ni ou la placer


merci d'avance

https://www.cjoint.com/c/IDBmcUaPcvl

    Posté le 27 avril, 14:04
    par Profaites
    Répondre
    0

    Bonjour,

    En D2 : =RECHERCHEV(C3;Produits!$A$2:$C$100;2;FAUX)

    En F2 : =RECHERCHEV(C3;Produits!$A$1:$C$100;3;FAUX)

    Pour optimiser, je nommerais la plage des références produits et j'utiliserais un tableau structuré.

    ouisansdoute Posté le 27 avril, 17:46
    par ouisansdoute
    • je te remercie mais pourrais tu être un peu plus explicite je débute merci – Profaites 27 avril, 18:22
    0

    Oui,

    je te renvoie le fichier. j'y ai ajouté des formules et des commentaires dans l'onglet produits et dans l'onglet magasin. Commence par l'onglet Produits. j'espère que cela clarifiera.

    Fichier commenté

    ouisansdoute Posté le 27 avril, 20:19
    par ouisansdoute
    • Un Grand merci pour ton aide – Profaites 29 avril, 12:37

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :