Comptage occurrences

0

Bonjour,

Nous sommes confrontés à un problème très simple.

Nous devons trouver combien d'élèves d'une liste de lycées sont originaires de ce dernier, puis nous devons récupérer ce nombre pour l'utiliser dans un courrier afin de personnaliser en accordant le verbe être au singulier ou au pluriel selon le nombre grâce à un classique "sinon si".
La règle d'accord au féminin fonctionne puisque nous nous basons sur le genre (M/F).

Nous disposons d'un fichier excel avec la liste de tous nos nouveaux entrants inscrits à 5 programmes sur 5 campus. 

A = numéro Etablissement (RNE/UAI)
B= nbe = comptage du nombre d’élèves originaires de l’établissement scolaire en colonne A
C= identité fusion = liste élèves du lycée avec retour à la ligne dans la cellule et concaténation du programme suivi ainsi que de son campus
D= "*" une formule pour sélectionner la colonne B avec le nombre d'élèves pour la fusion
F = numéro étudiant
G = Civilité
H = Nom complet
I = accord féminin courrier etc...

Notre méthodologie actuelle, mais qui ne marche que partiellement, consiste à compter le nombre d'élèves avec une formule : =NB.SI(A1:Ax;A1:Ax).
Pour cela c'est ok.

Là ou cela coince c'est pour isoler uniquement les lignes où la valeur de Nbe est la plus élevée qui correspond bien au total de élèves !

Nous avons utilisé une colonne en D = SI(A1=A2;"";"*")

Problème, des résultats parfois discordants et l'étoile n'est pas toujours placée pour le Nbe le plus élevé et la composition n'est pas certaine...

Si vous avez une proposition, nous vous serions infiniment reconnaissants !

Bien cordialement

Philippe


    Posté le 1 octobre, 08:29
    par Philippe
    Répondre
    0

    Bonjour,
    Philippe.

    Peux tu nous envoyer un fichier Excel exemple reprenant l'ensemble de tes colonnes et des données fictives.

    Ensuite mettre en jaune le lieu où tu veux qu'il y est des formules avec la valeur attendu pour nous assurer que le calcul effectué est bon.

    Tu peux nous envoyer cela via www.cjoint.com

    Cordialement,

    Tom

    Posté le 1 octobre, 10:51
    par Tom
    0

    Bonsoir,

    Voici le fichier nettoyé (les formules avec mais elles sont décrites dans la question), du moins les premières lignes.

    - https://www.cjoint.com/c/IJbpF7K3Pt4 

    Bien cordialement,

    Philippe


    Posté le 1 octobre, 17:38
    par Philippe
    0

    Bonsoir,
    Peux tu refaire le lien, car celui-ci est vide.

    Cordialement,

    Tom

    Posté le 1 octobre, 17:49
    par Tom
    • Mettre bien diffusion public et durée illimitée – Tom 1 octobre, 17:50
    0

    Bonjour,

    Oups, je ne sais pas ce qui s'est passé au moment du copier/coller !

    Bref, voici le bon normalement !

    - https://www.cjoint.com/data/IJbpF7K3Pt4_Classeur1.xlsx

    Bien cordialement,

    Philippe

    Posté le 2 octobre, 08:36
    par Philippe

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :