Enlever des cases de la selection

1

Bonjour,

J'ai une question toute bête. Je veux par exemple calculer la moyenne d'un jeu de donnée (disons A1:K10) mais je souhaiterais que la case C7 ne soit pas prise en compte. Y-a-t-il un moyen simple de le faire dans la formule =Somme(A1:K10) ?

    Posté le 10 octobre, 23:44
    par Jean
    Répondre
    1

    Bonjour,

    Tu peux faire la fonction :

    =MOYENNE(A1:B10;C1:K6;C8:K10;D7:K7)

    Sélectionne les cellules autour de C7 avec CTRL

    Cordialement,

    Tom

    Posté le 11 octobre, 11:50
    par Tom
    1

    @Tom

    Bonjour,

    Merci pour cette réponse mais malheureusement, je n'ai pas qu'une seule case a enlever. Sur un bloc donné (taille carré), je dois ne pas prendre en compte toute la diagonale. Votre solution fonctionne aussi dans mon cas mais me demanderais des formules à rallonge, ce que je ne souhaite pas. Existe-t-il pas une autre manière plus "automatique" à rentrer dans une formule ?


    Quelques chose comme =Somme(A1:K10-C7-D8-A3) m'arrangerait mais cela ne semble pas être possible, je me trompe?

    Posté le 11 octobre, 13:42
    par Jean
    1

    Bonjour,

    il y a ça sinon :

    Cette formule fonctionne si ta diagonale commence en A1 pour faire la somme uniquement des valeurs en diagonale

    =SOMMEPROD((A1:K10)*(COLONNE(A1:K10)=LIGNE(A1:K10))*1)

    Cette formule fonctionne si ta diagonale commence en C7 pour faire la somme uniquement des valeurs en diagonale

    =SOMMEPROD((A1:K10)*(LIGNE(A1:K10)-COLONNE(A1:K10)=4))*1

    POUR ta moyenne :

    =(somme(A1:K10)-SOMMEPROD((A1:K10)*(LIGNE(A1:K10)-COLONNE(A1:K10)=4))*1)/(nbval(A1:K10)-(Ligne(K10)-Ligne(K7))


    Cordialement,

    Tom

    Posté le 14 octobre, 12:38
    par Tom
    • ERRATUM =SOMMEPROD((C7:K10)*(LIGNE(C7:K10)-COLONNE(C7:K10)=4))*1 – Tom 14 octobre, 13:48

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :