Problème somme de plusieurs cellules dont certaines sont vide message d'erreur

1

Bonjour à tous,
j'essaie de faire un tableau récapitulatif de notation.
Un exercice par feuille et une feuille ou devront apparaitre la somme de la note de chaque exo.

Jusque là ça va...

Je pensais naïvement m'y prendre ainsi :

='Exercice I'!B5+'Exercice II'!B5+'Exercice III'!B5+'Exercice IV'!B5+'Exercice V'!B5

Le problème c'est que certaine cellule que je dois sommer contiennent le mot "ABS" qui apparait à l'aide de cette formule :

=SI(ET(ESTVIDE(C6);D6;E6;F6;G6;H6);"Abs";((C6+D6+E6+F6+G6+H6)/($C$3+$D$3+$E$3+$F$3+$G$3+$H$3))*$B$2)

 J'ai essayé plusieurs manières de sommer ces cellules mais je pense qu'il faudrait rajouter dans "le code" quelque chose pour lui dire de sommer uniquement les cases contenant un chiffre et d'ignorée celles qui affichent "Abs"
Mais je ne sais pas du tout comment m'y prendre...
Quelqu'un peut-il m'aider?

Remarque : J'avais trouvé une solution barbare qui consistait à recopier la valeur des cellules à sommer dans un coin pour m’affranchir des formules mais je voudrais faire ça proprement...

Matnat Posté le 30 octobre 2014, 22:15
par Matnat
Répondre
1

J'ai essayé en utilisant la fonction SOMME à la place de l'opérateur +, et ça marche :

=SOMME('Exercice I'!B5;'Exercice II'!B5;'Exercice III'!B5;'Exercice IV'!B5;'Exercice V'!B5)
Vince Posté le 3 novembre 2014, 12:14
par Vince

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :