Si a present dans b inscrire quantité de c

1

J'ai deux liste a comparer et si mon article est present je veux inscrire la quantité qui se trouve dans c, sinon ecrire 0

    Posté le 19 mai, 18:02
    par Paraiiba
    Répondre
    0

    Bonjour,


    1-) Un on dit "BONJOUR"

    2-) On expose explicitement sa demande avec si possibilité un exemple

    3-) On remercie par avance

    Et là, la réponse sera plus rapide et précise


    Posté le 19 mai, 18:29
    • Bonjour! comment allez vous en cette magnifique journée! Permettez moi de vous demander comment vous portez vous en cette période de confinement? Ici tout se passe bien malgré tout. Cellule A contient tout mes articles, cellule B les articles qu'un de mes magasins contient et cellule C se trouve la quantité que je possède de la cellule B. Est -il possible d'avoir une formule qui recherche dans A ce qui se trouve dans B et inscrire la valeur de C. Actuellement je suis capable de faire afficher seulement si l'article est présent donc 1 ou 0 voici la formule que j'utilise =SI(ESTNA(RECHERCHEV(A1;$B$1:$B$3506;1;0));"0";"1") Un gros merci a l'avance veuillez agréer l'expression de mes sentiments les meilleurs – 19 mai, 19:09
    0

    Bonsoir,

    J'ai recherché à reproduire le tableau tel qu'il est décrit mais je ne comprends pas bien la relation qu'il y a entre ces trois colonnes. Alors je vais répondre de façon un peu plus générale.

    La fonction RECHERCHEV peut fonctionner dans ton cas puisque les quantités à reprendre sont en colonne C mais encore faut-il que la matrice ne soit pas B1:B3506 mais B1;C3506

    Dans ce cas, on récupère la valeur de la deuxième colonne de la matrice (soit la colonne C) en mettant 2 au lieu de 1 comme troisième argument.

    Donc je transforme un peu ta formule, je remplace la toute dernière partie par la valeur de la colonne C si le texte recherché est trouvé (je répète donc la partie de formule avec RECHERCHEV

    =SI(ESTNA(RECHERCHEV(A1;$B$1:$B$3506;1;0));"0";RECHERCHEV(A1;$B$1:$C$3506;2;0))

    Dans le premier RECHERCHEV, pas besoin d'étendre la sélection, le but est de savoir si le texte est trouvé ou non. Sa valeur, on s'en fiche royalement à cet endroit. 

    En revanche, dans le deuxième RECHERCHEV, il faut bien étendre la sélection et choisir la deuxième colonne.

     Cette fonction a toutefois un inconvénient majeur, les éléments de la zone de recherche doivent obligatoirement être classés par ordre croissant.

    Si la liste n'est pas classée, il faudra dans ce cas trouver une autre solution avec EQUIV() et INDEX()

    Bon courage


    MicXL Posté le 20 mai, 18:09
    par MicXL

    Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
    Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :