EVITER LES DOUBLONS

0

Bonsoir,
On m'a chargé depuis peu, de l'organisation des inscriptions d'un club sportif.
Je m'intéresse donc au VBA pour me faciliter la tâche.
Mes connaissances en programmation sont très limitées, mais, grâce à internet, je suis parvenu à faire une base de données contrôlée par un formulaire de saisie.
Cette boite de dialogue me permet d'inscrire des nouveaux candidats mais aussi de modifier le statut de personnes déjà inscrites.

Je suis à la recherche d'un code VBA qui me permettrait de me signaler si un doublon simultané sur trois colonnes (Nom, Prénom, Date naissance) est détecté.

Merci d'avance pour votre aide.

François

Tchantchès Posté le 9 février 2021, 19:06
par Tchantchès
Répondre
0

Bonjour,

Sans passer par du code VBA, tu peux créer deux colonnes. Une première dans laquelle du concatène les trois valeurs à tester (par exemple en colonne D : D1 ->  =A1 & B1 & C1)

Dans une autre tu cherches le nombre de valeurs répondant au critère de comparaison

En E1 -> = NB.SI(D1:D100;D1)

ouisansdoute Posté le 28 février 2021, 17:09
par ouisansdoute

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :