Somme des cellules visibles dans Excel

0

Bonjour,

Je me heurte à un problème de somme des lignes visibles dans un tableau.

La fonction =SOUS.TOTAL(109;C2:C10) fonctionne très bien pour une somme en colonne, mais la même fonction =SOUS.TOTAL(109;C2:L2) ne fonctionne pas pour une somme en ligne.

Il en est de même en VBA avec le code suivant :

Function SommeCellulesVisibles(Plage As Range) As Double

Dim plg As Range

Dim Total As Double

For Each plg In Plage

If plg.Rows.Hidden = False And plg.Columns.Hidden = False Then

Total = Total + plg.Value

End If Next SommeCellulesVisibles = Total

End Function

Je ne comprend pas pourquoi cette différence entre les colonnes et les lignes.

Quelqu'un pourrait-il éclairer ma lanterne ? .... et accessoirement me dire comment faire la même chose en version horizontale ? (❁´◡`❁)

Merci


JoBar Posté le 10 octobre, 16:05
par JoBar
Répondre
0

Question résolue par ailleurs avec la formule ci-dessous, merci tout de même à ceux qui se sont penchés sur la question

=SOMME(DECALER(B41:AF41;0;0;1;JOUR(FIN.MOIS($B$7;0))))
JoBar Posté le 11 octobre, 17:16
par JoBar

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :