Somme des X premières colonnes d'un tableau

1

Je souhaite additionner un nombre de colonnes, ce nombre étant lui même le résultat d'un calcul, par ex sur un tableau de 40 colonnes, une cellule en dehors de ce tableau me donne 15, et donc je voudrais additionner les 15 premières colonnes.

Posté le 17 novembre 2016, 09:51
par cb
Répondre
0

Bonjour,


A tester pour modèle  http://www.cjoint.com/c/FKrjODETw35

Posté le 17 novembre 2016, 10:41
par M12
1

Bonjour,

je n'ai pas eu le résultat escompté (si j'ai bien compris la question de cb) avec lexemple de M12

je pense que la formule (pour la ligne 2...) est plutôt :

=SOMME(A2:INDIRECT(CAR(Feuil2!$B$2+64)&LIGNE(A2)))

Feuil2!$B$2 étant la référence de la cellule contenant le nb de colonnes à aditionner

CAR(Feuil2!$B$2+64) permet d'obtenir la lettre de la 'nb'ième colonne,

LIGNE(A2) le n° de ligne courant, pour que la recopie s'incrémente bien,

INDIRECT permettant d'utiliser des formules pour obtenir une référence de cellule

Posté le 2 décembre 2016, 11:26
par RBi

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :