Utiliser la même sélection verticale pour plusieurs formules différentes

0

J'ai, sur la même ligne, une cellule avec une formule "moyenne", et une autre cellule, à côté, avec la formule "lignes", comment puis-je faire pour que ma formule ligne se serve de la sélection (cible) de la formule moyenne de façon automatique.

azerty11235 Posté le 10 avril 2015, 10:04
par azerty11235
Répondre
1

Voici ce que je propose en utilisant la formule INDIRECT.

 

ABCD
DonnéesMoyenneNombre de donnéesZone
12=MOYENNE(INDIRECT(D2))=LIGNES(INDIRECT(D2))A2:A4
13
14

Ainsi, on ne change que les références qui sont contenue dans la cellule D2 (en mettant A2:A5 si on insére une valeur à la cellule A5, par éxemple) et les formules MOYENNE et LIGNE se calculent automatiquement.

oly Posté le 10 avril 2015, 16:05
par oly
  • Je viens de faire un essai, et ça marche! Merci encore pour l'aide. – azerty11235 10 avril 2015, 16:18
  • de rien. :-) – oly 10 avril 2015, 17:27
0

On peut utiliser, peut-être, la formule "INDIRECT" mais pour être sûr, il faudrait qu'on voie votre éxemple.

oly Posté le 10 avril 2015, 14:19
par oly
1

Je vais faire des essais avec INDIRECT (je ne la connais pas), en attendant voici ce que j'ai :

(je n'arrive pas à poster l'image, donc j'ai tenté de le reproduire ici)

     /        A                  /               B          /          C                    /

  1 /       données        /   moyenne          /nombre de données/

  2 /         12                /=moyenne(A2:A4)/ =lignes(A2:A4)      /

  3 /          13               /

  4 /          14               /

 

azerty11235 Posté le 10 avril 2015, 14:47
par azerty11235

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :