Fusionner lignes excel 2010

0

Bonjour,

Je dois établir une base de donnée clientèle : réunir en un fichier excel un listing clients avec plusieurs informations.

J'ai comme base trois fichiers excel contenant chacun des clients avec leurs informations. Mais certains clients figurent dans les trois fichiers.

En réunissant les trois fichiers j'ai des doublons: plusieurs lignes pour un même client, mais avec des informations différentes sur le client. J'aimerais fusionner ces lignes en une seule ligne réunissant toutes les informations contenu par chaque ligne.

Exemple :
code client/Nom Client/ email/ Tel
789456321/Duponettti/ /0603...
789456321/Duponettti/d@g.c/

Je voudrais :
789456321/Duponettti/d@g.c/0603...

Merci

Posté le 21 mai 2015, 08:59
par fanff
Répondre
1

Tu peux saisir dans ta nouvelle ligne la formule suivante :

=A1 & SI(B1="";"";" " & B2) & SI(C1="";"";" " & C1) & SI(D1="";"";" " & D1) & SI(E1="";"";" " & E1) ...

Posté le 28 mai 2015, 07:38
par ouisansdoute
  • Je me suis trompée de réponse. – ouisansdoute 28 mai 2015, 07:40
  • Je procéderais de la façon suivante : 1 - extraire la liste des numéros de clients (via un filtre avancé sans doublons sur un nouvel onglet) 2 - dans les colonnes suivantes utilisation d'une recherchev Par exemple (je suppose que ta base est A1:D50) De A2 à A50 A les numéros de clients en B2 : =RECHERCHEV(A2;$A1:D50;2;FAUX) Puis recopie de la formule en ligne et en colonne. – ouisansdoute 28 mai 2015, 07:48

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :