Combiner 2 formules en une seule cellule

0

Bonjour,

J'ai regardé différentes réponses sur ce forum sans trouvé ma réponse.

Je possède une cellule ou je souhaite mettre deux formules dedans.

Les formules sont les suivantes 
=SI(C3="ALEX";0;0) car je souhaite que si c'est marqué ALEX la valeur soit 0.
La seconde formule est la même mais avec un autre Prénom
=SI(C3="DENIS";5;5) Car je souhaite que quand c'est écrit DENIS la valeur soit 5.

J'ai donc essayé avec différentes séparation mais je ne trouve pas la bonne, j'ai juste eu une réussite avec & mais qui possède également un soucis car ma formule donne

=SI(C3="ALEX";0;0)&SI(C3="DENIS";5;5)

Le problème c'est que dans ma cellule il affiche 05 car il prend en compte le 0 de la valeur fausse de ALEX celui en gras dans la formule
=SI(C3="ALEX";0;0)&SI(C3="DENIS";5;5)

Je suis débutant sur Excel, je commence à comprendre le principe mais la je suis bloqué, un personne serait capable de m'aider ?

Merci

Posté le 9 novembre, 14:47
par Alexandre
Répondre
0

J'ai donc chercher à mettre la formule sous d'autres formes etc et j'ai trouvé en ayant fait ceci

=SI(C3="ALEX";0;SI(C3="DENIS";5))

Et la cellule affiche bien ce que je cherche, donc si c'est écrit ALEX en C3 il me mets bien 0 dans ma cellule et si c'est écrit DENIS il me mets 5.

Je le partage si ça peut servir ^^

Posté le 9 novembre, 15:15
par Alexandre
0

Bonjour Alexandre,

je te propose cette formule :

=SI(C3="ALEX";0;SI(C3="DENIS";5;7))

* pour ALEX, tu auras 0

* pour DENIS, tu auras 5

* si c'est ni ALEX, ni DENIS, tu auras 7 ; alors
si besoin, remplace 7 par une autre valeur.

edit : on s'est croisés.  ;)

rhodo

rhodo Posté le 9 novembre, 15:18
par rhodo
  • Au moins ça me rassure que ma formule, et oui le 7 je l'ai fait avec ESTVIDE, j'ai réussi à bien pousser la formule ;) – Alexandre 9 novembre, 16:23
0

@Alexandre

tu as écrit : « le 7 je l'ai fait avec ESTVIDE »

alors ce n'est pas bon, car la fonction ESTVIDE() est pour tester si une cellule est vide :

=ESTVIDE(C3) retourne VRAI si la cellule C3 est vide ; sinon ça retourne FAUX.

et ce ne sont pas les textes "VRAI" et "FAUX" : ce sont les valeurs booléennes
VRAI et FAUX (ce qui nest pas la même chose !).

donc si tu veux que ça retourne une chaîne de caractères vide, mets cette formule :

=SI(C3="ALEX";0;SI(C3="DENIS";5;""))

après « 5; », ce sont 2 guillemets.

rhodo

rhodo Posté le 9 novembre, 16:33
par rhodo

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :