Imbriquer plusieurs NB.SI

2

Bonjour,

J'ai un tableau avec des désignations de produit et j'aimerais que s'affiche dans la case d'à côté un mot en fonction d'une lettre présente dans la première case.

En résumé,
si ma case contient la lettre B, le mot BAC s'affiche
si ma case contient la lettre C, le mot CROSS s'affiche
si ma case contient la lettre P, le mot PALETTE s'affiche

J'arrive à utiliser une condition avec la formule suivante =SI(NB.SI(C15;"*B*");"BAC") mais je ne parviens pas soumettre plusieurs conditions

Merci d'avance pour votre aide

Posté le 22 juillet 2015, 16:58
par JP
Répondre
2

Salut le Forum

=CHOISIR(CODE(GAUCHE(MAJUSCULE(C15);1))-64;"Art";"BAC";"Cuisine")
Liste à compléter pour les lettres de D à Z
Mytå Posté le 22 juillet 2015, 19:50
par Mytå
2

Bonjour,

Autre solution :

=SI(A3="B";"BAC";SI(A3="C";"CROSS";SI(A3="P";"PALETTE";"INCONNU")))

Cette solution se rapproche de ta démarche mais la solution de Myta est astucieuse.

Merci de confirmer si cela t'a aidé.

A+

Posté le 21 août 2015, 17:25
par CHRIS

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :