Liste deroulante avec formule

-1

Bonjour à tous,

Je cherche un moyen de reproduire une liste déroulante avec comme choix différentes formules qui permettraient le calcul de la colonne selon le choix effectué.

Pouvez vous m'aider ?


Merci d'avance :)

Posté le 13 juin, 19:37
par Ruwsback
Répondre
-1

Bonjour,

A ma connaissance, on ne peut pas le faire mais rien n'empêche de mettre une liste déroulante avec ce que tu souhaites (par exemple "Addition, Multiplication Soustraction, Division" et ensuite, tu as le choix :

Soit le calcul est simple et dans ce cas-là, tu as une formule du genre :

=SI(A1="Addition";A2+A3;SI(A1=Multiplication";A2*A3;SI(A1="Soustraction";A2-A3;SI(A1="Division";A2/A3;"?"))))

Si les calculs sont plus complexes, je conseille de faire tous les calculs dans une colonne qui sera masquée et avec le même principe, si c'est le premier calcul, on va chercher la valeurs dans les calculs masqués.

En espérant que ça réponde à ta question.

Bon courage.

MicXL Posté le 14 juin, 12:50
par MicXL

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :