Liste déroulante

3

Bonjour à tous,

Je chercher à faire une liste déroulante dans laquelle je puisse faire une recherche et interroger ma base.

J'ai trouvé une formule sur un forum que je ne comprends pas bien et que j'ai du mal à modifier. Cette formule fonctionne relativement bien.

=SI(E3<>"";DECALER(Ville;EQUIV(E3;GAUCHE(Ville;NBCAR(E3));0)-1;;SOMME((GAUCHE(Ville;NBCAR(E3))=E3)*1));)

Cependant elle cherche seulement les mots qui sont à gauche dans mes cellule. Hors j'ai besoin que cette formule recherche dans la chaîne de caractère de chaque ligne pour me proposer tout ce qui correspond à ma recherche.

Je ne suis pas très claire, je sais, mais j'ai un peu de mal à expliquer ce que je vaux faire. Je mets le fichier où j'ai trouvé la formule que je cherche à modifier légèrement. Ainsi que mon fichier Excel.

Posté le 17 novembre 2016, 18:28
par Eugénia
Répondre
3

Voici les liens 

file:///C:/Users/mcarret/Desktop/Classeur1%20(1).xlsm

Copie de Liste_Intuit_Recherche (1) (1).xls

Eugénia Posté le 17 novembre 2016, 18:33
par Eugénia
  • Ça ne peut pas marcher ça, c'est le chemin du fichier sur ton ordinateur, mais on ne peut pas y accéder via internet. Il faut partager le fichier sur http://www.cjoint.com/ pour qu'on puisse le télécharger ici. – Vince 20 novembre 2016, 17:56
1

Bonjour,

Tes liens ne fonctionnent pas.

Il est préférable que :

1 tu fasses un classeur projet de ce que tu désires faire : ta liste avec les différentes données ainsi que le tableau résultat que tu souhaites obtenir et nous mettrons les formules pour que cela fonctionne.  Cela ne sert à rien de transmettre le fichier exemple que tu as trouvé car il ne nous dira pas ce que tu désires obtenir.

2 quand tu auras fait ce fichier, tu passes par le site http://www.cjoint.com/ 

pour le charger sur le site ; créer le lien ; copier le lien et le coller dans le forum et nous pourrons alors le récupérer.

A bientôt

Chris

Posté le 17 novembre 2016, 19:28
par chris1945

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :