Additionner des nombres dans une meme cellule

-4

Bonjour

J'aimerais additionner des nombres présents dans une même cellule soient séparés par des virgules soient par des + :

Exemple :
1500+500+450 en A1 / comment obtenir la somme dans B1 ?
1500,500,450 en A1 / comment obtenir la somme dans B1 ?

À noter que la quantité de nombres présents dans la cellule n'est jamais la même.

Merci d'avance

Posté le 4 novembre 2015, 15:11
Répondre
-2

Tu peux essayer avec cette formule en B1 :

=SOMME((SUPPRESPACE(STXT(SUBSTITUE(A1;"+";REPT(" ";255));1+(LIGNE(A1:A999)-1)*255;255)) & "0")/10)

C'est une formule de tableau, il faut appuyer sur Ctrl+Maj+Entrée pour la valider, au lieu de simplement Entrée. Par contre elle ne marche qu'avec le séparateur "+", pas la virgule. Tu peux utiliser la fonction rechercher & remplacer pour remplacer tous les + par des , dans la colonne.

Sinon il y a une solution beaucoup plus simple mais il faut utiliser les macros pour créer une fonction EVAL, qui n'existe pas nativement sur excel : http://stackoverflow.com/questions/20921561/how-to-sum-values-seperated-by-semicolon-in-excel-cell

Vince Posté le 4 novembre 2015, 16:08
par Vince
0

parfait , ca fonctionne a merveille ! 

Est ce que tu peux m'expliquer la formule par contre ?

Merci

Posté le 4 novembre 2015, 16:48
-6

et encore un grand merci ! 

Posté le 4 novembre 2015, 17:54
-1

G E N I A L Vince !

Il m'a fallu un moment pour comprendre ....  Je retiens !

A+

Chris 


Posté le 4 novembre 2015, 19:14
par CHRIS
-2

Bonjour,

Je cherche une formule qui pour exercer un calcul si dans une même cellule j'ai deux chiffre avec un espace et un +.

exemple: 

1 + 51 en A1 (sachant que 1 c'est une chambre triple et 51 une chambre double)

pouvez-vous m'aider

Posté le 13 août 2018, 18:18
  • mon calcule est ci-dessous et ça ne calcule pas SI.CONDITIONS(A1<=50+>=51;(E22-D22+1)*5) – 13 août 2018, 18:21

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :