Sous total dynamique avec prise en compte de la dernière ligne renseignée

-1

Est-il possible dans une formule de totalisation dynamique (SOUS.TOTAL) d'avoir la dernière ligne du champ qui s'actualise automatiquement selon le nombre de lignes alimentées

Exemple pour illustration :

En colonne A les lignes 3 à 2500 sont renseignée. La formule =SOUS.TOTAL(3;A3:A2500) me permet d'avoir un total dynamique fonction des valeurs sélectionnées via un filtre.

Ce même fichier peut le mois suivant avoir 3000 lignes ce qui m'oblige à mettre à jour la formule ou par défaut prendre un champ beaucoup plus étendu (exemple : A3:A10000)

Si possible je souhaiterai combiner cette formule avec la formule MAX.

Merci par avance à tous pour votre aide

Posté le 2 décembre 2015, 18:10
par philhype
Répondre
-1

Je ne sais pas si ça peut t'aider, mais voici une formule permattant d'obtenir la valeur de la dernière cellule remplie d'une colonne :

=SI(B11="";DECALER(B11;-SOMMEPROD(--(B$1:B11=""));0);B11)

Il y a peut-être moyen de récupérer l'adresse de cette dernière cellule et de l'utiliser dans une autre formule pour définir une plage.

Vince Posté le 7 décembre 2015, 14:39
par Vince

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :