Chercher une date entre 2 dates

0

Bonjour,

Je voudrais en fonction de cellules indiquant les bornes limites saisies au format date en dates (ex en A1 et B1), trouver la date la plus proche dans 1 plage de cellules (ex G1:Z1) qui donnent une série de dates sur plusieurs mois (ex : 3/1, 5/2, 4/3, 10/3...)

Pour l'instant, j'ai utilisé la formule =SOMMEPROD((H1:K1>=B1)*(H1:K1<=C1)*(H1:K1))

qui fonctionne bien tant que je n'ai pas plusieurs dates sur la même période. En effet dès qu'il y a plusieurs dates, cette fonction multiplie les différentes dates ! du coup j'ai essayé en ôtant la date max, mais ce n'ai pas satisfaisant si mes bornes sont inférieures aux dernières dates saisies.

Pouvez-vous aussi m'expliquer comment joindre 1 fichier en exemple sur le forum, je viens de m'inscrire.

Merci

fullmoon Posté le 11 mars 2016, 08:18
par fullmoon
Répondre
0

Bonjour,

Pour joindre un fichier :

Aller sur le site Cijoint : http://www.cjoint.com/

Charger le fichier ; créer le lien ; copier le lien et le coller dans le forum.

Cela sera en effet plus clair de comprendre tous tes cas de figures.

Par exemple s'il y a plusieurs  dates dans ta liste qui correspondent à ta fourchette ou encore plus embêtant une date 3 jours avant et une autre 3 jours après --> laquelle choisir ??

A bientôt

Chris

Posté le 11 mars 2016, 18:37

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :