Calcul des heures de nuit à partir des horaires début & fin

-1

Bonjour à tous,

Je vous sollicite car j'ai besoin de mettre en place une formule qui m'aiderait dans la gestion du personnel. Je vous explique.
J'ai besoin d'un fichier où je rentre simplement les horaires de début et fin du salarié, puis que ce fichier me donne :

  1. Le nombre d'heures effectuées dans la journée, sachant que si la durée de travail est supérieure ou égale à 8h, le salarié prend 30 minutes de pause.
  2. Le nombre d'heures de nuit, sachant que les heures de nuit vont de 21h à 6h du matin (Boulangerie).

Je suis parvenu à mettre le début en place avec les formats heures etc.... mais pour faire ressortir les heures de nuit, je n'y parviens pas.
J'ai vraiment besoin de votre aide, je suis certain que parmi vous de nombreux(ses) sauront comment me délivrer de ce casse-tête.
Je vous joins le fichier TEST avec les horaires sur une semaine d'un salarié.

Vous remerciant énormément par avance.
Yohan

Posté le 18 avril 2016, 01:25
par YOYOL94
Répondre
-1

Bonjour,

Pour fonctionner correctement, la date du jour doit être ajoutée à chaque heure d'arrivée ou de départ. En effet si une heure d'entrée est à 3:45, en réalité pour Excel  il s'agit de 3:45 le 00/01/1900.

Illustration de formules de calcul :

journée du 4/4/2016 (en A2)  heure d'arrivée (en C2) 3:45 et heure de sortie (en C3) 11:12

Formules pour les heures de nuit de avant 8:00 :

=SI(A2+C2<A2+(8/24);(A2+(8/24))-(A2+(C2));SI(A2+C2>=(A2+(8/24));0;))


Posté le 20 avril 2016, 14:38
par ouisansdoute
0

Bonjour Yohan, j'ai exactement la même demande que toi et je suis dans la même branche de travail. Cela fait une semaine que j'essaye de faire quelque chose qui tienne la route. Serais-tu d'accord de partager avec moi ton tableau? 

Merci d'avance pour ta réponse 

Posté le 28 mai 2016, 09:51
par Célia

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :