Moyenne sur une plage spécifiee par des bornes

1

Salut tout le monde, 

J'ai beaucoup cherché avant de poser la question ici, mais la j'avoue que je sèche! Merci d'avance a ceux qui m'aideront.

Voici mon problème:

J'ai une table de donnee avec sur chaque ligne un client et chaque colonne sa consommation mensuelle.

Je souhaite calculer la consommation moyenne de chaque client entre deux bornes: bornes inf et borne sup. Dans mon tableau la borne inf correspond au numéro de colonne a partir duquel je souhaite faire ma moyenne et la borne sup est le numéro de colonne jusqu’au quel je souhaite faire ma moyenne. 

Par exemple dans ma première ligne la borne inf est la colonne 5 et la borne sup est la colonne 71: j'ai beau chercher je ne trouve pas comment spécifier a excel que je veux qu'il calcule la moyenne depuis la colonne 5 jusqu’à la colonne 71...

Pouvez-vous m’éclairer sur la question?

Merci d'avance!

Posté le 3 avril 2016, 09:27
par makh
Répondre
0

Bonjour,

Essaies ceci : =SOMME(INDIRECT(ADRESSE(1;5;1;1)):INDIRECT(ADRESSE(1;71;1;1)))

Tu adaptes le 5 et le 71 en fonction des colonnes que tu veux couvrir

Le premier 1 indique la ligne.

A noter que ces chiffres peuvent naturellement être remplacé par des fonctions ou des références de cellules ainsi il y a moyen de complètement paramétrer la somme.

Exemple : je met en A2 : 5 et en A3 : 71.  La formule devient :

=SOMME(INDIRECT(ADRESSE(1;A1;1;1)):INDIRECT(ADRESSE(1;A3;1;1)))

Valable également pour le numéro de ligne.  

Les autres paramètres de la fonction adresse sont là pour déterminer si l'on désire un adressage absolu ou relatif et si l'on désire travailler aves des adresses sous la forme A1 ou L1C1. 

Je t'engage à aller lire l'explication des fonctions dans l'aide d'excel.  

A noter que INDIRECT ne fonctionne que dans un même classeur et que pour atteindre un autre onglet dans la fonction ADRESSE, il faut le spécifier dans le paramétrage (à la fin : ce paramètre n'est pas obligatoire donc je l'ai omis ici puisque tu travailles dans la même feuille)

La fonction ADRESSE permet ainsi de paramétrer ton adressage et la fonction INDIRECT permet de lire ce qui est contenu par cette adresse.

A+

Chris

Posté le 3 avril 2016, 10:03
par CHRIS

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :