Comparaison de deux cellules contenant 0 et -0

-1

Je compare 2 cellules A1 et B1 contenant respectivement 0 et -0

SI (A1= B1;C1="V";C1="F") Excel considère qu'elles ne sont pas égales : réponse F
Si j'utilise leurs valeurs absolues SI (ABS(A1)= ABS(B1);C1="V";C1="F") j’obtiens la même réponse F

Ma formule est-elle fausse ?
Comment résoudre ce problème ?

Merci d'avance pour toute solution

Posté le 2 avril 2017, 16:56
par ALC77
Répondre
-1

Bonjour,

-0 n'existe pas dans Excel mais par contre -0.1 avec comme format SANS décimal fera apparaître -0 dans la cellule mais en réalité il s'agit de -0.1 et donc cela expliquerait que ta comparaison ne donne pas l'égalité.  Vérifies le contenu exact de la cellule dans la barre d'encodage et tu verras que le nombre n'est pas 0

Si tu veux quand même tester sans les décimales tu peux procéder ainsi :

=SI(ENT(ABS(A1))=ENT(ABS(B1));VRAI;FAUX)

Comme tu le remarqueras, la syntaxe de ta formule n'était pas exacte : il ne faut pas indiquer à Excel la cellule réceptrice il est assez grand lui même pour savoir que c'est l'endroit où se trouve la formule.  Il suffit, après la condition, de mettre ; et la réponse positive et ; et la réponse négative

Autre point : si tu veux mettre sans "" il faut indiquer VRAI ou FAUX qui sont connus d'Excel par contre si tu veux mettre V et F il faut les mettre en "" : "V" et "F" car c'est du texte et pas du numérique qui seul peut être introduit sans "".

Merci de confirmer si cela répond à tes attentes.

A+

Chris

CHRIS Posté le 2 avril 2017, 18:36
par CHRIS

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :