AFFICHER la valeur à l'intersection d'une ligne et d'une colonne données

0

Bonsoir chers amis,

j'ai besoin de votre aide. j'ai dans un 1er tableau ( TABLEAU1) des sites avec des valeurs pour chacun des 12 mois de l'année. Dans un 2è tableau (TABLEAU 2) j'ai les même sites et j'ai créé un menu déroulant qui permet de choisir un mois quelconque. Je voudrais afficher la valeur correspondante  (du TABLEAU1) qui se trouve à la croisée du mois et du site concerné. Voici le fichier excel en question  https://www.cjoint.com/c/IIyr5JjKvl6

je sais qu'il faut une formule avec RECHERCHEV ou INDEX ou EQUIV  mais je ne sais pas comment la libeller, j'ai essayé cette formule dans la cellule B23 du fichier

RECHERCHEV(A25;$A$2:$M$18;(equiv(B2;$B$2:$M$18;0);FAUX)
mais visiblement je fais n'importe, je continue mes recherches mais je me tourne vers vous pour augmenter mes chances. 

merci

FICHIER EXCEL  https://www.cjoint.com/c/IIyr5JjKvl6

matsniper Posté le 24 septembre, 20:09
par matsniper
Répondre
0

Bonjour les experts,

 Après mon post j'ai trouvé une solution qui marche. c'est un peu long et j’étais obligé d'insérer une ligne en dessous des mois afin de récupérer les numéros de colonnes dont j'avais besoin pour utiliser la fonction RECHERCHEV combinée à la fonction RECHERCHEH. 

en résumé :

(voir fichier joint https://www.cjoint.com/c/IIzk5qeyc66 )

avec la ligne insérée, B23 devient B24
en B24=RECHERCHEV(A24;$A$2:$M$19;$D$23;FAUX)
avec $D$23=RECHERCHEH(B23;B2:M3;2)
en combinant ces deux formules en B24 on aura : B24=RECHERCHEV(A24;$A$2:$M$19;RECHERCHEH($B$23;$B$2:$M$3;2);FAUX)

Un ami m'a suggéré une formule qui marche très bien, à mettre en B24:

RECHERCHEV(A24;$A$2:$M$19;EQUIV($B$23;$A$2:$M$2;0);FAUX)

Pas besoin d'insérer une ligne pour récupérer un numéro de colonne.

matsniper Posté le 25 septembre, 12:58
par matsniper
0

Bonjour Mat,


Je te propose également cette solution.

Si tu donnes des noms a tes colonnes et ligne :

https://www.cjoint.com/c/IIzm0nAwYiT

Voila ce que ça donne

Tom Posté le 25 septembre, 14:53
par Tom
0

Merci Tom ! simple sans bavure

Tu es un vrai super héros, tu me permets de bien comprendre l'utilisation de cette fonction INDEX. J'avoue qu'elle me faisait beaucoup réfléchir car je ne cernais pas bien son fonctionnement.

MERCI ENCORE

matsniper Posté le 25 septembre, 16:06
par matsniper
0

Mat,

je te met ça ici

https://www.excel-exercice.com/intersection-ligne-colonne-sans-formule/

et ca

https://www.commentcamarche.net/faq/35004-nommer-des-plages-trouver-une-intersection-ligne-colonne


c'est comme ça que j'ai trouvé la solution a ton problème.

Le seul truc c'est que tes noms ne doivent pas avoir d'espace et des "_" à la place.


Cordialement;

Tom

Posté le 25 septembre, 17:39
par Tom

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :