Comparaison de nombres

0

Bonjour, je débute sur Excel et j'aimerais comparer 3 nombres pour leur attribuer une valeur en Fr. Comment procéder?

Posté le 19 mars, 11:27
par Fred
Répondre
0

Bonjour Fred,

Puisque tu débutes, il faut commencer par le début et donner beaucoup plus de précision.

On compare 2 choses et si ce sont des nombres on compare si l'un est plus grand, plus petit, égal ou différent. Si on veut comparer plus de nombres, soit il faut faire plusieurs comparaison en chaîne (par exemple, si A > B, alors je regarde si B > C) ou alors, il y a des fonctions qui comparent plusieurs nombres, comme MAX qui trouve la plus grande valeur d'une série de nombre.

Il semble que tu aies besoin de comparer des nombres 2 à 2, alors il y a la fonction SI qui s'écrit de la façon suivante :

=SI(Condition;ValeurSiVrai;ValeurSiFaux)

Je vais prendre un exemple simple.

Les frais de livraison de 12€ sont offerts à partir de 150€ de commande.

Imaginons qu'en D10 j'ai le total de la facture

En D11, j'écris la formule

=SI(D10>=150;0;12)

Je traduis : Si le contenu de la cellule D10 est supérieur ou égal à 150, alors je lis ce qu'il y a juste après le premier point-virgule, c'est-à-dire zéro, sinon, je prends la valeur après le deuxième point-virgule, c'est-à-dire 12.

https://support.office.com/fr-fr/article/si-si-fonction-69aed7c9-4e8a-4755-a9bc-aa8bbff73be2

Cet article du support technique te donnera beaucoup plus de précisions.

Toutefois, si tu peux apporter plus de précisions sur ce que tu dois comparer, on peut t'aider plus, bien entendu. Tu peux aussi utiliser le site https://www.cjoint.com pour y déposer ton fichier, en prenant soin de supprimer les données personnelles.

Bon courage et bonne découverte d'Excel.

MicXL Posté le 19 mars, 16:47
par MicXL
0

Merci pour la réponse. Je précise ma demande. Nous sommes trois joueurs de Rami. J'entre les résultats dans un tableau Excel et en fin de partie chacun doit mettre de l'argent dans la cagnotte. Donc, si à la fin de la partie les totaux sont les suivants(345; 890; 236) je dois avoir les sommes correspondantes suivantes (60 €; 70 €; 50 €), donc comparer trois nombres. J'arrive facilement avec deux valeurs, mais pas avec trois.

Posté le 19 mars, 20:39
par Fred
0

Bonjour,

Heureusement que vous êtes trois et pas quatre... tu vas voir pourquoi

Je reformule pour savoir si j'ai bien compris : Il y a 3 cellules avec le total des points des trois joueurs, et en dessous, il y a le montant à apporter à la cagnotte en fonction des points. Celui qui a le maximum de points a 70€, celui qui a le minimum de points a 50€ et celui qui est intermédiaire a 60€ (d'où ma joie tout à l'heure. Vous êtes trois, il n'y a qu'un seul intermédiaire. Sinon, la suite ne fonctionnerait pas.

Je mets les points dans les cellules B20 C20 et D20 (ça laisse de la place au dessus pour mettre les points de chaque partie) et en B21, j'écris la formule suivante :

=SI(B20=MAX($B$20:$D$20);70;SI(B20=MIN($B$20:$D$20);50;60))

Première comparaison, si la cellule au-dessus est égale à la valeur maxi de la plage B20:D20 (avec des $ pour faire des références absolues pour recopier la formule), alors la valeur est de 70. Sinon, on fait une autre comparaison

Si la cellule au-dessus est égale à la valeur mini de la plage B20:D20, alors la valeur est de 50. Sinon, les valeurs extrêmes ayant été traitées, ça ne peut être que la valeur intermédiaire donc la valeur est 60.

Une remarque cependant, si deux personnes ont le même nombre de points, il y aura dans ce cas deux fois 70€ ou deux fois 50€

En espérant avoir répondu à ta question.

Bonne journée.

MicXL Posté le 20 mars, 07:45
par MicXL
  • Un tout grand merci pour cette excellente explication qui correspond en tout point à mon attente. C'est un plaisir d'avoir des gens compétents pour nous aider à résoudre nos problèmes. A bientôt peut-être pour une autre intervention. En espérant que l'affreux Coronavirus ne vous atteigne pas. – Fred 20 mars, 07:56

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :