formules #NOM?

-1

Bonjour

J'ai trouvé sur le forum ceci

1) tu vas dans les options d'excel rubrique formules et tu y mets calcul en manuel et tu coches itératif avec 1 en nbre maxi d'itérations. Tu quittes en faisant OK

2) dans la feuille qui te convient, tu sélectionnes la zone A1:A90 et tu saisis la formule matricielle :

=ALEAS(90;1;90;nouveau<>"ok")
 que tu valides par CTRL+MAJ+ENTER 

3) en B1 : 
=SI(ET(E1>0;E1<91);"tirage n° "& E1 &" : ";SI(nouveau="ok";"merci d'effacer le ok";SI(E1=0;"faire <F9> pour lancer le tirage";"")))


4) en C1 : 
=SI(E1=91;"Fin du tirage";SI(nouveau="ok";"";SI(E1>0;INDEX($A$1:$A$90;$E$1);"")))


5) en E1 : 
=SI(nouveau="ok";0;SI(E1=91;91;E1+1))


6) en G1 : tu saisis le texte nouveau jeu

7) en H1 : tu définis le nom nouveau

Le principe de fonctionnement : 
+A1:A90 contient la séquence aléatoire des valeurs tirées sans remise. 
+pour réinitialiser la séquence aléatoire, il faut saisir ok dans nouveau (H1) puis l'effacer pour pouvoir lancer les tirages. 
+on effectue les tirages de 1 à 90 en faisant <F9> (recalcul manuel) 
+quand tu arrives à 90, tu bloques tant que tu n'as pas relancé une nouvelle séquence avec le ok précédent (en H1). 
+tu caches les colonnes A et E. E1 sert de compteur qui s'incrémente à chaque recalcul grâce à la référence circulaire et au calcul itératif autorisé mais limité à une boucle.

J'ai mis comme indiqué toutes les formules en place , mais j'ai de A1:A90 B1 C1 et E1 #NOM?, 
et en appuyant sur F9 rien ne ce passe 
Ne pourrait-on pas le faire en VBA?
Merci encore

Posté le 1 février 2015, 10:41
par mic6259
Répondre
1
Mytå Posté le 1 février 2015, 18:26
par Mytå
  • Oui je l'ai mais le tri se fait mal car on retrouve souvent les mêmes numéros après plusieurs mises à zéro – mic6259 1 février 2015, 20:02

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :