Formule pour trouver un equilibre entre débits et crédits

-1

Bonjour,

Je souhaiterais savoir s'il existe une formule ou solution à ce problème :
Pour mon travail actuel, je dois équilibrer des montants (crédits et débits) avec leurs contraires.

Pour vous donner un exemple:
Un client reçoit un crédit de 3524.19€
L'équivalence en note de frais est de 9.13€ + 587.12€ + 400.01€ + 2130.24€ + 397.69€
Et cela se présente de la manière suivante dans mon logiciel :

3524.19
9.13-
587.12-
400.01-
2130.24-
397.69-

Cependant quand je possède plusieurs crédits et plusieurs notes de frais, l'ordre n'est pas respecté et les chiffres se mélangent :
Exemple: 3254 = 254 +1500 +1500 et 3207 = 1200 + 800 + 207

3524
207-
1800-
1500-
254-
3207
1200-
1500-

Et le logiciel ne faisant pas la relation entre les crédits et les débits, je dois retrouver les montants correspondants manuellement.
Cependant comme la liste est longue les chiffres à virgule, le travail est fastidieux.

Ainsi je voulais savoir s'il existe une formule qui puisse me trouver des équilibres entre les débits et les crédits et si c'est le cas, comment s'appelle-t-elle et comment s'utilise-t-elle ?

Merci d'avance.

Posté le 4 novembre 2016, 12:01
Répondre
-1

Bonsoir,

Ne connaissant pas la structure de votre fichier, vous pouvez créer 2 colonnes supplémentaires : crédit (col B) puis débit (col C), si l'extraction de votre fichier est en colonne A :

en colonnne B : =SI(DROITE($A2;1)="-";"";A2)

en colonne C : =SI(DROITE($A2;1)<>"-";"";CNUM(GAUCHE($A2;NBCAR($A2)-1)))


Vous avez certainement un élément à votre réponse, si vous souhaitez automatiser la transaction, c'est possible.


Matthieu CHENAL



MatBase Posté le 4 novembre 2016, 19:44
par MatBase

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :