Surbrillance SI

1

Comment faire en sorte que toute une plage sélectionnée devienne rouge lorsque 51% des cellules renseignées contiennent un 0 ?

Merci

Posté le 9 décembre 2016, 15:40
par Gautier
Répondre
1

Avec un code VBA. Par exemple

For Each Cellule In Plage
	X = 0
	Y = 0
	If Cellule = 0 Then
		X = X + 1
	Else
		If Cellule > 0 Then
			Y = Y + 1
		End If
	End If
Next
Call Nettoyer

If X > Y / 2 Then
	Plage.Select
	With Selection.Interior
		.Pattern = xlSolid
		.PatternColorIndex = xlAutomatic
		.Color = 65535
		.TintAndShade = 0
		.PatternTintAndShade = 0
	End With
End If
Posté le 9 décembre 2016, 21:28
par ouisansdoute
1

En ôtant la ligne Call Nettoyer qui renvoyait à un code pour effacer les couleurs

Posté le 9 décembre 2016, 21:29
par ouisansdoute
2

Bonsoir :

1 Sélectionner la plage

2 cliquer sur Mise en forme conditionnelle

3 Choisir Nouvelle règle / sélectionner : utiliser une formule

4 mettre la formule suivante :  =NB.SI($A$1:$A$20;"=0")>=NB($A$1:$A$20)*51%

5 régler la mise en forme  avec remplissage rouge

et la sélection se mettra en fond rouge si le % de 0 est = ou supérieure à 51 %

Voilà un exemple : http://www.cjoint.com/c/FLmahYsPXYN

Tu cliques sur le lien et tu récupères le classeur

A+

Chris


Posté le 12 décembre 2016, 01:09
par chris1945

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :