Fonction SI et liste déroulante

0

Bonjour, 

J'explique mon petit souci

J'établis une facture automatisée. Sur celle-ci il y a 3 types de service optionnels et additionnels. J'ai donc mis une liste déroulante pour indiquer le choix des clients (données de la liste "oui" et "/").

Dans chaque type de service, il y a plusieurs choix possibles avec un montant différent exemple (réf. f01 - "descriptif" - montant)

Pour les descriptifs et les montants, j'ai insérer une fonction RECHERCHEV (pour être plus précis: une Si+EstNA+RechercheV) qui se réfère à la référence (donc f01 par exemple).

J'aimerais savoir s'il est possible de faire:

Une fonction SI

Si vrai alors une liste déroulante est disponible avec les références des choix possibles
Si faux, 0 (ainsi, grâce à la fonction Si + EstNA, j'obtiens un 0€ pour ce service la)

Merci d'avance,

Timothée 

https://www.cjoint.com/c/HBlpRJFs8uc

Posté le 11 février, 16:52
par SecondeVie
Répondre
1

Une piste pour ton problème :

Une plage est nommées liste

La formule de validation est =SI(A13=VRAI;Liste;$B$1)

https://www.cjoint.com/c/HBmifaCkKHR

NB : Il faudrait ajouter une petite macro qui remettre le champ à vide quand la valeur testée change.


ouisansdoute Posté le 12 février, 09:08
par ouisansdoute
0

Merci de ta réponse.

J'ai essayé ta piste, qui s'est révélée bonne mais qu'à moitié

En fait, quand la valeur est FAUX, pas de soucis, mais quand la valeur est VRAI, la case où j'ai inséré la formule (dans la case de la liste déroulante), la formule disparait et est remplacée par un choix de la liste déroulante...

Il faudrait peut être noter la formule dans une cellule quelconque, mais comment faire pour qu'elle modifie une autre?

Posté le 12 février, 12:33
par SecondeVie

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :