Rechercher dans quelle fourchette de prix se trouve une valeur

0

Bonjour,

J'ai un montant que j'aimerai situer dans une fourchette de prix d'un tableau

Exemple : 67,8   

(Comment faire en sorte qu'il utilise la formule B, étant dans la fourchette 51 à 100)

f60b70d0d2.png

Tam Posté le 15 décembre 2019, 20:16
par Tam
Répondre
0

Bonsoir,

Il suffit d'imbriquer plusieurs fonctions SI les unes dans les autres. Le plus difficile est de ne pas oublier une parenthèse.

Le principe est le suivant : Si(montant est inférieur ou égal au seuil haut, alors c'est la formule A, sinon on continue de chercher.

Pour plus de compréhension je vais l'écrire sur plusieurs lignes. On peut aussi l'écrire sur plusieurs lignes en tapant ALT ENTREE.

=SI(F2<=B2; [Formule A];
SI(F2<=B3; [Formule B];
SI(F2<=B4; [Formule C];
SI(F2<=B5; [Formule D];
SI(F2<=B6; [Formule E];
SI(F2<=B7; [Formule F]; 0))))))

J'ai préféré mettre B2 B3 .... B7 parce que si les seuils changent, il n'y a pas besoin de refaire la formule. Ce n'est pas idéal de mettre des valeurs dans les formules. On repasse plusieurs mois plus tard et on a oublié.

Je pense qu'on peut aussi résoudre cette formule avec la fonction CHOISIR, c'est moins lourd à gérer que cette imbriquation de SI ou alors, vu que les seuils sont indiqués dans un tableau trié, avec la fonction RECHERCHEV.

Bon courage.

MicXL Posté le 15 décembre 2019, 23:00
par MicXL
  • Merci beaucoup MicXL, J'avais finalement fait une formule interminable mais c'est pas très pratique : =SI(ET($F$2>=A2;$F$2<=B2);C2; SI(ET($F$2>=A3;$F$2<=B3);C3 SI(ET($F$2>=A4;$F$2<=B4);C4 Bonne journée – Tam 16 décembre 2019, 10:56
  • En effet, dans les comparaisons en chaîne, on n'a à comparer qu'une fois. Mais la solution de Chris est bien plus simple et plus pertinente. En plus, sa solution fonctionne avec beaucoup plus de seuils sans beaucoup de modifications. – MicXL 17 décembre 2019, 00:56
3

Bonsoir,

Je me permet de suggérer une autre alternative en utilisant les fonctions EQUIV et INDEX à savoir

=INDEX($C$2:$C$7;EQUIV($F$2;$A$2:$A$7;1);1)

La fonction EQUIV avec le type 1 recherche la valeur la plus petite inférieure à la valeur cherchée ainsi nous connaissons la ligne dans le tableau.  Il suffit alors d'utiliser la fonction index avec comme matrice la colonne C pour trouver la formule. 

Regarde dans l'aide d'Excel qui explique très bien comment utiliser les fonctions EQUIV et INDEX

Je joins ton tableau complété.

https://www.cjoint.com/c/ILqbnjKu3Tz

Tu cliques sur le lien et tu suis les instructions pour récupérer le classeur Excel

La prochaine fois que tu viens sur le site, fais pareil pour nous envoyer ton classeur, cela évite que nous devions recommencer ton tableau.

Bonne continuation

Chris


CHRIS Posté le 16 décembre 2019, 02:17
par CHRIS
  • Bonjour CHRIS, Super gagne temps avec cette méthode, merci beaucoup. Bonne journée – Tam 16 décembre 2019, 11:07
  • Superbe suggestion, Chris. Ça aurait été bien dommage de nous en priver. – MicXL 17 décembre 2019, 01:00
  • Content que cela vous plaise. A bientôt – CHRIS 17 décembre 2019, 02:48

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :