Moyenne de cellules avec détection de cellules vide

0

Bonjour, 

j'ai une série de champs de 6 cellules chacun dans lesquels je rentre des données numériques. et à la fin je fais les moyennes des 6 cellules dans chaque champ. Il se trouve que les 6 cellules ne contiennent pas toujours des valeurs, il se peut que quelques unes d'entre elles soient vides. 

Je voudrais savoir comment automatiser la tache qui est de faire une moyenne de ces 6 cellules, en n'incluant que les cellules contenant des valeurs. 

A noter que dans ma formule de la moyenne je multiplie chaque cellules par un facteur, voici ma formule:

MOYENNE(A1*2;A2*4;A3*6; A4*8;A5*10;A6*12)

si une des cellules est vide il va la considérer comme étant = 0 (qui est en soi une valeur) et il va à la fin diviser le tout par 6.

Merci pour votre aide


ramo8964512 Posté le 14 juin 2014, 14:22
par ramo8964512
Répondre
3

Difficile de t'aider sans avoir un document excel d'exemple. A priori, tu peux t'en sortir en utilisant la fonction somme produit, avec une formule de ce style :

=SOMMEPROD(A1:A6;{2;4;6;8;10;12})/NB.SI(A1:A6;">0")

Si ça ne fonctionne pas, tu peux tenter le coup avec les fonctions SOMME et NB :

=SOMME(A1*2;A2*4;A3*6;A4*8;A5*10;A6*12) / NB(A1:A6)

Enfin, si tu utilises excel 2010 ou une version plus récente, jette un oeil à la fonction AGREGAT ici : http://office.microsoft.com/fr-fr/excel-help/agregat-fonction-HA010338704.aspx

Vince Posté le 15 juin 2014, 16:57
par Vince
0

Okay Vince, merci pour ta réponse :)

Posté le 20 juin 2014, 20:17
0

Ca marche, merci Vince pour ta réponse

ramo8964512 Posté le 29 février 2016, 11:53
par ramo8964512

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :