RechercheV qui affiche #N/A

3

Bonjour, je bloque sur une formule que j'utilise normalement sans trop de soucis qui est : =RechercheV( ; ; ;)

Voici un lien Cjoint pour consulter le DOC Excel qui sert à restituer les infos d'une base de donnée : https://www.cjoint.com/c/HFzsbqoyw0U


Avez vous une solution à mon problème ? 

Titi


titi Posté le 25 juin 2018, 20:05
par titi
Répondre
3

Bonsoir,

Voici ton fichier en retour corrigé.

Il ne s'agissait que d'un mauvais paramétrage de la fonction (probablement lors d'un copier coller)

J'ai également adapté pour que la liste déroulante fonctionne.

A+

Chris

https://www.cjoint.com/c/HFAath8gM0t


CHRIS Posté le 26 juin 2018, 02:22
par CHRIS
3

Je souhaiterai faire pareil mais comment puis je restituer le numéro client (Colonne B) étant donné que le tableau commence 'Colonne C' dans ton tableau par exemple ?

=RECHERCHEV(C2;Contacts_Formulaire!C3:K8; Colonne précédente   ;FAUX)


Tam Posté le 26 juin 2018, 13:19
par Tam
  • Ah j'ai trouvé , si tu as besoin il faut utiliser "INDEX" et "EQUIV" pour aller de droite à gauche. a+ – Tam 26 juin 2018, 14:06
4

Bonsoir,

Effectivement ces 2 fonctions répondent également aux besoins de recherche.  Elles sont un peu plus compliquées à utiliser mais elles offrent l'avantage de pouvoir faire la recherche vers la gauche comme vers la droite.

Comme le demandeur avait utilisé RECHERCHEV, j'ai proposé la correction nécessaire pour que sa formule puisse fonctionnner

A+

Chris


CHRIS Posté le 28 juin 2018, 01:06
par CHRIS
4

Merci beaucoup Chris et Tam pour votre aide, tout fonctionne ! A+

titi Posté le 28 juin 2018, 20:06
par titi

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :