Additionner les X plus grands chiffres avec Excel

5

Bonjour, je souhaite additionner les 10 plus grandes valeurs d'une liste. J'ai essayé avec la fonction SOMME.SI (SUMIFS) mais le critère est statique :

=SOMME.SI(B3:B22;">=65")

Est-ce qu'il y a moyen d'améliorer la formule en utilisant une autre fonction qui utilise un critère "dynamique" ?

Merci

Posté le 16 juin 2013, 14:41
par overbelle
Répondre
5

Pas besoin d'une nouvelle fonction, il faut utiliser la fonction GRANDE.VALEUR (us: LARGE) pour calculer dynamiquement le critère :

=SOMME.SI(B3:B22;">="&GRANDE.VALEUR(B3:B22;10))

Cette fonction additionne les 10 plus grands chiffres de la liste.

Posté le 16 juin 2013, 14:45
par truxer
  • Merci pour cette formule, seulement elle à un hick, si 2 fois la même valeur, elle va les additionner les 2. Je m'explique, si 3 donnée et veut faire la somme des 2 plus haute (après adaptation de la formule) j'ai par exemple, 100, 50 et 50, elle me donne 200 en résultat et non 150, alors que si j'ai 100, 50 et 49,9 elle me donne 150. En gros, cette formule ne prend pas en compte l'extraction du doublon. Quelqu'un sait comment résoudre ce souci ? Merci – 2 décembre 2014, 03:33
  • GRANDE.VALEUR(B3:B22;1)+GRANDE.VALEUR(B3:B22;2)+GRANDE.VALEUR(B3:B22;3)+GRANDE.VALEUR(B3:B22;4)+GRANDE.VALEUR(B3:B22;5)+GRANDE.VALEUR(B3:B22;6)+GRANDE.VALEUR(B3:B22;7)+GRANDE.VALEUR(B3:B22;8)+GRANDE.VALEUR(B3:B22;9)+GRANDE.VALEUR(B3:B22;10) – 30 janvier 2016, 02:12
4
essai avec cette fonctio, elle devrai marcher; =SOMMEPROD(GRANDE.VALEUR(plage_data;LIGNE(1:10)))
Posté le 13 juillet 2016, 19:34
par nbaky
  • essai avec cette fonction, la somme des 10 plus grandes valeurs d'une plage – nbaky 13 juillet 2016, 19:36
  • merci ! ça marche – 25 octobre 2016, 09:48
0

Pourquoi ne pas utiliser tout simplement :

=SOMME(GRANDE.VALEUR(plage_data;LIGNE(1:10)))

Formation Excel

Posté le 14 mars, 18:52

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :