Afficher une valeur dans une cellule selon plusieurs critères différents

0

Bonjour à tous,

Dans le cadre de mon travail je dois réaliser un calculateur agronomique pour la fertilisation phosphatée. 
J'ai dans un fichier excel un onglet "sources" comprenant plusieurs tableaux de données :

- Les régions
- Les types de sols liés à cette région
- Les valeurs Trenforcé et T impasse selon le type d'exigence d'une culture, et selon la région et le type de sol.

Dans un autre onglet "DoseP2O5K2O" je souhaite effectuer un calcul de coefficient en fonction de différents critères présnts dans les données de l'onglet "Sources" et de l'onglet "DoseP2O5K2O"

J'ai essayé tout d'abord de faire correspondre les valeurs de "T impasse" et "T renforcé" en fonction de la région dans laquelle se trouve la culture, du type de sol, et enfin du niveau d’exigence de la culture. 
Ma formule ressemble à ça : =SIERREUR(DECALER(INDEX(Sources!$C$38:$H$124;EQUIV(DoseP2O5K2O!$B7&DoseP2O5K2O!$C7;Sources!$A$38:$A$124&Sources!$B$38:$B$124;0);EQUIV(DoseP2O5K2O!$E7;Sources!$C$36:$H$36;0));;1);"")
Mais aucun résultat ne s'affiche quand je fais Maj+ctrl+entrée. Et je ne comprend pas pourquoi !!

J'aimerai également de J30 à J47 afficher les coefficient pour le calcul des doses de P2O5. Ce coefficient se calcule en fonction de l'exigence de la culture(E7:E24), de la teneur en P2O5 d'un sol (I30:I47) donné par rapport aux "T impasse" et "T renforcés" (ou T impasse -10%, 2x T impasse, etc), et enfin du nombre d'années sans apports depuis la dernière fertilisation. Le tableau correspondant à ces valeurs se trouve dans l'onglet "Sources", et est numérotés 3a/.
Un exemple pour trouver le coefficient : on a une culture moyennement exigeante, sans apport de fertilisation depuis 0 années, et avec une teneur du sol en P2O5 de 165 mg/kg de terre. On se trouve donc dans la colonne entre T impasse et T impasse +10%. le coefficient correspondant est donc 0 !

Tout cela est assez compliqué donc je met le fichier correspondant en pièce jointe !

Cependant je suis assez nulle dans tout ces genres de calculs, j'aurais donc aimé savoir si vos compétences pouvais m'éclairer la dessus. J'espère que quelqu'un pourra m'aider dans ma besogne. 
Merci d'avance à tous ceux souhaitant plancher sur mon problème !

elodu22

elodu22 Posté le 14 février 2014, 15:22
par elodu22
Répondre
-1
elodu22 Posté le 14 février 2014, 15:22
par elodu22
1

Le lien vers le fichier excel ne fonctionne pas, pourrais-tu indiquer l'URL où on peut le télécharger ?

Sinon, concernant ton problème, c'est difficile de t'aider sans avoir la feuille, mais il me semble qu'il existe des plugins excel spécialisé dans les calculs agronomiques (genre statbox vision ou statbox vegetal), peut-être que ça pourrait t'aider.

Vince Posté le 16 février 2014, 11:36
par Vince

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :