SOMMEPROD

1

Bonjour la forum,

J'ai besoin d'aide. Je ne trouve pas mon erreur dans la formule suivante :

=SOMMEPROD((A24:A63=500)*(GAUCHE(C24:C63;1)="F");(D24:D63))

en A j'ai des sections 500, 1000, 1500, etc

en C j'ai des rubriques "F  - Façonnage xxxx"; "F  - Façonnage yyy"; "hfjhfjhkjq"

et en D j'ai des CAHT

Je souhaite donc par exemple avoir le total de CA pour la section 500 et des sous rubriques commençant par un "F".

Je pourrais éventuellement le faire avec des somme.si.ens mais cela ne marche pas avec des fichiers fermés alors qu'avec sommeprod, il parait que cela marche avec des liaisons avec des fichiers fermés.

D'avance, merci de votre aide

Pascalito 67

Posté le 22 septembre 2014, 18:00
par pascalito67
Répondre
-2
=SOMMEPROD((A24:A63=500)*(GAUCHE(C24:C63;1)="F")*(D24:D63))

Mets * et non ; avant D24:D63

Steelson Posté le 23 septembre 2014, 21:56
par Steelson
-1

Sorry : je me suis trompé de cadre

Bonjour,

Voici une proposition qui devrait convenir pour obtenir des informations se trouvant dans un classeur fermé :

Classeur fermé : Classeur2

Feuille1

Plages : A1:A14   -   B1:B14   -   C1:C14

Dans le classeur de calcul mettre la formule MATRICIELLE suivante :

=SOMMEPROD(SI(('C:\[Classeur2.xlsx]Feuil1'!$A$1:$A$14=500);1;0)*(SI(GAUCHE('C:\[Classeur2.xlsx]Feuil1'!$B$1:$B$14;1)="F";1;0))*('C:\[Classeur2.xlsx]Feuil1'!$C$1:$C$14))

Merci de confirmer si cela vous a aidé ou si vous désirez un complément d'informations

Chris


Posté le 1 février 2015, 12:26
par CHRIS

Si vous n'êtes pas inscrit sur le site, vous pouvez poster librement (en tant qu'invité).
Pour cela, indiquez un pseudonyme (nom d'utilisateur) et une adresse email :